USB EFI Boot/Install

Home Page Forums users USB EFI Boot/Install

  • This topic is empty.
Viewing 6 reply threads
  • Author
    Posts
    • #29241
      miansancor
      Participant

      Hello everyone.
      Very good day.

      I have tried to install openmamba and I can’t.
      I have experience installing Linux, this is the first time I have had these errors.

      I have downloaded the three isos, I have copied them with dd, balena etcher and gnome disks and when I start the booting process, after the grub message they always show this, in normal boot, or the two advanced boot

      EFI stub: Loaded initrd from LINUX_EFI_INITRD_MEDIA_GUID device path
      EFI stub: Measured initrd data into PCR 9

      Can anyone help me with this?

      Thank you

       

      Attachments:
      You must be logged in to view attached files.
    • #29244
      Silvan
      Keymaster

      Hi,
      I suppose you get these messages, then the live system won’t boot.

      By doing a first search there are two recent posts discussing these boot messages:
      https://forums.debian.net/viewtopic.php?p=792227
      https://forums.gentoo.org/viewtopic-t-1167043-start-0.html

      The appearance of these messages might be due to the combination of recent Kernel and Grub releases, but they might not be the real cause of the kernel not booting.

      If this is the case it would be useful to see the boot kernel messages by booting with debug grub entry, but probably you already tried this and did not get any more useful message, maybe because the problem happens before the kernel has initialized the framebuffer to display messages on video. What kind hardware have you tried to boot it on?

      I will go on checking if I can sort out or reproduce any new problems since latest distribution updates.

    • #29246
      miansancor
      Participant

      Thanks a lot for your replay Silvan!I’ve used a laptop and a PC, both intel motherboard.

      On the two the error messages was the same on this quite different hardware. Since I tested in two differents machines, and it is the very first time a found such a problem, I don’t understand the matter.

      I’ve checked https://forums.debian.net/viewtopic.php?p=792227 both forum, but my problem is that the processo booting stop at the very begining.Thanks for any help Silvan.

      Are you italian? Io ho vissuto diversi anni in Italia! Parlo bene anche l’italiano.

       

    • #29247
      miansancor
      Participant

      Hello everyone.
      I have tried to start my USB with the latest iso, on another PC, where pclinuxos is already running, the kernel does not start there either. It stops in the same place as the other two computers, where there is already a Linux OS running.

      I have been using Linux for years, it has never happened to me that an iso does not start on three different PCs.
      I thought that I would not have downloaded it correctly, I have repeated it three times, with three different programs I have copied it to two different USB keys, the SAME RESULT.

      I don’t know if there would be another older ISO to try, as long as it can be updated to the KDE 6 version.

      Thanks for any help

    • #29248
      Silvan
      Keymaster

      Hello,
      when I receive this kind of reports soon after autogenerated monthly live media are released I’m urged to check that there has not been a regression which would prevent any or most user to install openmamba in the way and on the targets it worked before. According to what I verified this is not the case and there does not seem to be such a general problem. I will write next what I’ve done for the interest of your specific case.

      1) I’ve downloaded the currently available livecd ISO image (openmamba-livecd-en-snapshot-20240501.x86_64.iso)
      2) yesterday I’ve run it in a VM using both libvirt (which emulates a BIOS but) and VirtualBox (configured to emulate EFI boot), in both case I was able to correctly boot the system
      3) today I’ve prepared an USB pendrive using the dd command as per the instructions that are in the downloads page, i.e. with such a command issued from a Linux console:
      sudo dd if=openmamba-livecd-en-snapshot-20240501.x86_64.iso of=/dev/sdx bs=32M
      (as you say you have experience on Linux so I skip here details on preventing and checking that the procedure has not resulted into errors, which would be displayed on the console after the dd command).
      4) I’ve booted the system from the pendrive on a laptop with EFI boot and all worked as expected: Grub menu appeared, the O.S. booted, the KDE Plasma desktop opened and the Calamares installation tool started.

      Because you say that you tried the medium on three different PCs with same results, and because I have tested that there are no specific problem, my first guess would be that the USB pendrive + the ISO image written on it are causing the problem. Because you tried the 3 different ISOs (livecd, livedvd, livecd-light) probably it is not a download problem where an MD5 checksum check would be useful, so the other possibility would be that the pendrive has been not correctly prepared or produces read errors in the early boot of the system. Another guess it that you may have some settings on all PCs, like secure boot enabled and/or related settings, that might cause the difference from my results. Third guess, of course when you see the black screen with the messags you reported, you should wait for some tenth of seconds before decreeing that the system does not boot.

      When everything suggested above fails, I would go for trying to get more detailed boot messages, you say you already tried to start with debug boot option in grub, evidently with no more useful messages displayed, maybe we might try to enable initramfs debug options, which I will search, if necessary, in a next replay.

      Finally, yes, I am italian and openmamba is too. You may find an italian flag towards the top right corner of this page, by clicking there you will find this forum in italian language. If you manage to fix the problem, will have other questions about openmamba and like to write italian, you may want to write in the italian forum next time 🙂

      • This reply was modified 1 month, 1 week ago by Silvan.
      • This reply was modified 1 month, 1 week ago by Silvan.
    • #29250
      miansancor
      Participant

      Hi Sivan.
      Thank you very much for the time you have taken to explain all this to me and in such detail.

      I have downloaded the iso that you indicated again, I have used a new USB key, I have done the MD5 addition and again the same errors.

      But… It occurred to me to put that “pendrive” directly into one of the front ports of the PC and… IT HAS WORKED.
      I have already been able to see the splendid work you have done.

      I have a couple of questions before installing it, if you would be so kind.

      1st – I have read that it uses rmp and the apt system similar to debian. But in the “live system” that parameter is not there. I prefer the terminal to install programs.
      2nd – Do you use a software store other than discovery? Type of gnome or similar?

      Thank you very much Silvan for the help.

    • #29252
      Silvan
      Keymaster

      Hi,
      I’m very happy that you managed to solve the problem and appreciated openmamba in its live execution.

      Here are the replies to your questions:

      1) openmamba uses rpm packages and the low-level install/update manager is dnf. Both have been for years maintained as distribution indipendent projects and are used in Fedora and other distros. I know that there are sources reporting that it uses apt but this has changed over a decade ago 🙂

      2) the recommended desktop experience with openmamba is with Plasma 6 desktop which offers discover to install and update packages. For the LXQt lightweight desktop alternative I’ve provided dnfdragora.

Viewing 6 reply threads
  • You must be logged in to reply to this topic.