logout shutdown and reboot don’t work with deconnection screen activated

Home Page Forums users logout shutdown and reboot don’t work with deconnection screen activated

Viewing 5 reply threads
  • Author
    Posts
    • #29085
      ouaille_aime_scier
      Participant

      Hi Silvan,

      When I activate the deconnection screen in the configuration panel, logout, shutdown and reboot dashboard buttons don’t work, it seems that the screen don’t launch to let the user confirming command.

      Thanks in advance for your help.

    • #29086
      Silvan
      Keymaster

      Hi,
      it’s not clear to me what you mean with “When I activate the deconnection screen in the configuration”, this is normally activated by default and when you try to logout, reboot, shutdown etc., for instance from the bottom buttons in the application launcher menu, this screen appears for confirmation. So, you simply mean that you can never normally logout, reboot or shutdown from Plasma or are you describing a particular situation?

      If your case is the general issue this is not normally reproducible (those buttons are tested as working for me on many installations), so something bad may be happening on your particular installation and the cause might be reported in the user or system journal. You may want to check there or send a system report generated by the tools tyou may find in the applications menu.

      If, on the contrary, the problem is reproducible in a particular case, can you please explain me better which configuration changes you have made and where you are clicking to ask for logout, reboot, etc. Thanks.

    • #29087
      ouaille_aime_scier
      Participant

      Hi,
      it’s not clear to me what you mean with “When I activate the deconnection screen in the configuration”, this is normally activated by default and when you try to logout, reboot, shutdown etc., for instance from the bottom buttons in the application launcher menu, this screen appears for confirmation. So, you simply mean that you can never normally logout, reboot or shutdown from Plasma ?

      Yes Silvan,

      If I keep the default setting to have the logout confirmation screen the buttons to turn off or restart the machine or log out don’t work, but the other buttons work (standby, locking, changing user).

      By deactivating the deconnection screen, all buttons are working fine.

      Thanks.

    • #29092
      Silvan
      Keymaster

      Hello,
      I don’t reproduce the problem, I’ve also tried both X11 and Wayland sessions and searched in KDE bugs.
      Can you open a terminal and run:
      journalctl -f

      then try to logout to reproduce the problem and see if some useful message appears on the terminal?

    • #29094
      ouaille_aime_scier
      Participant

      Hello,
      journalctl -f
      then try to logout to reproduce the problem and see if some useful message appears on the terminal?

      Hi Silvan,
      This is what appears in the terminal :

      mars 30 20:15:09 openmamba dbus-daemon[6819]: [session uid=1000 pid=6819] Successfully activated service 'org.kde.LogoutPrompt'
      mars 30 20:15:09 openmamba ksmserver-logout-greeter[8068]: kde.logout_greeter: Couldn't find a theme for the Shutdown dialog ""
    • #29097
      Silvan
      Keymaster

      Hi Silvan,
      This is what appears in the terminal :

      mars 30 20:15:09 openmamba dbus-daemon[6819]: [session uid=1000 pid=6819] Successfully activated service 'org.kde.LogoutPrompt'
      mars 30 20:15:09 openmamba ksmserver-logout-greeter[8068]: kde.logout_greeter: Couldn't find a theme for the Shutdown dialog ""

      Hi,
      this seems like a theme problem. Are you using the default theme? If so, can you try to reapply it from the Appearance > Global theme page in the settings? It is not necessary to check the box for reapplying also the dispositions so that you won’t lose your customization.

      • This reply was modified 11 months ago by Silvan.
      • This reply was modified 11 months ago by Silvan.
      • This reply was modified 11 months ago by Silvan.
      • #29101
        ouaille_aime_scier
        Participant

        Hello Silvan,

        With OpenMamba default theme, deconnection screen appears fine.

        Thanks for your help.

Viewing 5 reply threads
  • You must be logged in to reply to this topic.