[Resolved] IBus Anthy does not work.

Home Page Forums users IBus Anthy does not work.

Tagged: 

Viewing 4 reply threads
  • Author
    Posts
    • #28927
      usuha
      Participant

      Hello.
      I’m using openmamba LXQt.
      I installed “IBus Anthy” to build a Japanese input system.
      But IBus Anthy doesn’t work.
      If anyone knows how to solve this problem, please let me know.
      Thank you.

      [usuha@openmamba ~]$ sudo dnf install ibus-anthy zenity
      Failed to set locale, defaulting to C
      Last metadata expiration check: 0:20:22 ago on Mon Nov 30 18:55:45 2020.
      Dependencies resolved.
      =========================================================================================================================================================================================================
      Package Architecture Version Repository Size
      =========================================================================================================================================================================================================
      Installing:
      ibus-anthy x86_64 1.5.11-1mamba rolling 1.2 M
      zenity x86_64 3.32.0-1mamba rolling 4.5 M
      Installing dependencies:
      anthy x86_64 9100h_37536-1mamba rolling 6.7 M
      libanthy x86_64 9100h_37536-1mamba rolling 176 k
      libibus-anthy x86_64 1.5.11-1mamba rolling 22 k

      Transaction Summary
      =========================================================================================================================================================================================================
      Install 5 Packages

      Total download size: 13 M
      Installed size: 37 M
      Is this ok [y/N]: y
      Downloading Packages:
      (1/5): libanthy-9100h_37536-1mamba.x86_64.rpm 83 kB/s | 176 kB 00:02
      (2/5): libibus-anthy-1.5.11-1mamba.x86_64.rpm 59 kB/s | 22 kB 00:00
      (3/5): ibus-anthy-1.5.11-1mamba.x86_64.rpm 162 kB/s | 1.2 MB 00:07
      (4/5): zenity-3.32.0-1mamba.x86_64.rpm 179 kB/s | 4.5 MB 00:25
      (5/5): anthy-9100h_37536-1mamba.x86_64.rpm 176 kB/s | 6.7 MB 00:38
      ———————————————————————————————————————————————————————————————————
      Total 305 kB/s | 13 MB 00:42
      Running transaction check
      Transaction check succeeded.
      Running transaction test
      Transaction test succeeded.
      Running transaction
      Preparing : 1/1
      Installing : libanthy-9100h_37536-1mamba.x86_64 1/5
      Running scriptlet: libanthy-9100h_37536-1mamba.x86_64 1/5
      Installing : anthy-9100h_37536-1mamba.x86_64 2/5
      Installing : ibus-anthy-1.5.11-1mamba.x86_64 3/5
      Running scriptlet: ibus-anthy-1.5.11-1mamba.x86_64 3/5
      Installing : libibus-anthy-1.5.11-1mamba.x86_64 4/5
      Running scriptlet: libibus-anthy-1.5.11-1mamba.x86_64 4/5
      Installing : zenity-3.32.0-1mamba.x86_64 5/5
      Verifying : anthy-9100h_37536-1mamba.x86_64 1/5
      Verifying : ibus-anthy-1.5.11-1mamba.x86_64 2/5
      Verifying : libanthy-9100h_37536-1mamba.x86_64 3/5
      Verifying : libibus-anthy-1.5.11-1mamba.x86_64 4/5
      Verifying : zenity-3.32.0-1mamba.x86_64 5/5
      New leaves:
      ibus-anthy.x86_64
      libibus-anthy.x86_64
      zenity.x86_64

      Installed:
      anthy-9100h_37536-1mamba.x86_64 ibus-anthy-1.5.11-1mamba.x86_64 libanthy-9100h_37536-1mamba.x86_64 libibus-anthy-1.5.11-1mamba.x86_64 zenity-3.32.0-1mamba.x86_64

      Complete!
      [usuha@openmamba ~]$

    • #28928
      usuha
      Participant

      sorry.
      I don’t know how to format content using BBCodes.

    • #28931
      usuha
      Participant

      Hello.
      I’m using openmamba LXQt.
      I installed “IBus Anthy” to build a Japanese input system.
      But IBus Anthy doesn’t work.
      If anyone knows how to solve this problem, please let me know.
      Thank you.

      $ sudo dnf install ibus-anthy zenity
      $ sudo nano ~/.bashrc
      export GTK_IM_MODULE=ibus
      export XMODIFIERS=@im=ibus
      export QT_IM_MODULE=ibus

      • This reply was modified 1 month, 2 weeks ago by usuha.
    • #28933
      Silvan
      Keymaster

      Hi Usuha,
      sorry for the delay.

      An update of ibus will be available in the next hours but this is probably an optional requirement to fix your issue.

      The most important thing is that I noticed that ibus-daemon just needs to be started before the desktop session. To accomplish this you may want to try to create a file ~/.xprofile with the following content:

      export QT_IM_MODULE=ibus
      export GTK_IM_MODULE=ibus
      export XMODIFIERS=@im=ibus
      ibus-daemon -drx

      Then you may remove the lines you added to .bashrc and reboot.

      With this configuration I get a ibus tray icon on the bar where I can change the input method and this now seems to work in KDE Plasma applications.

      • This reply was modified 1 month, 1 week ago by Silvan.
    • #28935
      usuha
      Participant

      Dear Silvan

      Hello.

      Thank you for teaching me how to resolve the IBus Anthy configuration.
      I was able to enter Japanese.
      I am very happy.
      Thank you very much.

Viewing 4 reply threads
  • You must be logged in to reply to this topic.