[Support request] ethernet Realteck

Home Page Forums users ethernet Realteck

Viewing 10 reply threads
  • Author
    Posts
    • #28900
      ouaille_aime_scier
      Participant

      Hello all,

      My machine has an ethernet controller Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15).
      The last iso snapshot doesn’t recognize this network card, so I can’t have Internet connection.

    • #28901
      Silvan
      Keymaster

      Hi,
      can you please provide the output of the dmesg and/or openmamba-makereport commands from terminal?

      `
      dmesg > ~/Desktop/dmesg.txt
      sudo openmamba-makereport
      `

      The generated files can be sent to us via Support -> Send a report or attached to a post in this thread.

    • #28902
      ouaille_aime_scier
      Participant

      Hi Silvan,

      Thanks for your quick post. I will do it tonight.

      I would point out that this version of OpenMamba does not recognize my Intel wifi card either.

    • #28903
      ouaille_aime_scier
      Participant

      It seems that the r8169 and iwlwifi drivers are well. But the network interfaces are not activated. I have looked at systemd services but I saw nothing wrong in first look.
      I join the openamamba-report file in case of.

      Attachments:
      You must be logged in to view attached files.
    • #28905
      Silvan
      Keymaster

      Hi,
      thanks for the information provided.

      It seems that the NetworkManager package is missing in recent livecd ISOs.

      If you are just running the live system I suggest waiting for a new release which I’m scheduling for tomorrow.

      If you have the system installed the problem might be fixed by manually configuring networking and running sudo dnf install NetworkManager or manually downloading and installing the NetworkManager package and its dependencies using an external storage device, e.g. a USB pendrive. Feel free to ask more details if you need more details in this case.

    • #28906
      ouaille_aime_scier
      Participant

      Thanks Silvan I could wait for the next iso to make a proprer installation.

    • #28907
      ouaille_aime_scier
      Participant

      I have reinstalled the distro with the recent ISO and the network is fonctionnal thanks 🙂

      I have two more little problems now :
      – my sound card is not initialized by the kernel with this error in journalctl “openmamba kernel: skl_hda_dsp_generic skl_hda_dsp_generic: unsupported HDAudio / iDisp configuration found” I tested several solutions found on the web but none was successfull (my sound card is 00:1f.3 Audio device: Intel Corporation Cannon Point-LP High Definition Audio Controller (rev 30) )
      – the Plasma interface is not fully translated in french my native language and I can select the lang in the configuration center

      Thanks for advance for you ideas 🙂

      • #28908
        Silvan
        Keymaster

        Hi,
        for the sound card problem I’ve looked for the different solutions proposed on the web and wonder if you have tried this:

        sudo su
        echo "options snd-intel-dspcfg dsp_driver=1" > /etc/modprobe.d/snd_intel_dspcfg.conf
        

        (then reboot).

        About the french language, a method would have been to start by using the livedvd ISO image which provides support for french by selecting the language at boot.

        Instead, switching language on a system installed from livecd requires some manual changes:

        1) make sure that the system-wide LANG environment is set to french, this can be done by editing as root the file /etc/locale.conf and replace the existing line with:

        LANG=fr_FR.UTF-8
        

        2) install the french langpack:

        sudo dnf install langpacks-fr
        

        3) configure the rpm %install_langs macro in file /etc/rpm/macros.lang:

        %_install_langs en:fr:fr_FR
        

        4) packages need to be updated or reinstalled so that translation files for the languages specified in 3) will be kept on local installation

        • This reply was modified 1 week, 5 days ago by Silvan.
        • This reply was modified 1 week, 5 days ago by Silvan.
    • #28911
      ouaille_aime_scier
      Participant

      Hi Silvan,

      Thank you very much for all your help. I will try your different options as soon as possible and let you know if things have improved.

    • #28912
      ouaille_aime_scier
      Participant

      Hello Silvan,

      Unfortunately your modprobe option was not successful, I still do not have my sound card recognized on my system, I continue to look for the solution on my side.

      Thanks a lot for your support.

    • #28913
      ouaille_aime_scier
      Participant

      Hi Silvan,

      Good news, I found the solution for my sound card problem.

      I have put in

      /etc/modprobe.d/blacklist :
      blacklist snd_soc_skl
      blacklist snd_sof_pci

      /etc/modprobe.d/alsa-base.conf :
      options snd-hda-intel dmic_detect=0

      Thanks for your help.

    • #28915
      Silvan
      Keymaster

      Hi,
      good, thanks for finding and sharing the solution to this problem.

Viewing 10 reply threads
  • You must be logged in to reply to this topic.