WiCD and dbus not connecting

Home Page Forums users WiCD and dbus not connecting

This topic contains 4 replies, has 3 voices, and was last updated by  Silvan 9 years, 5 months ago.

  • Author
    Posts
  • #11490

    Piki
    Member

    When I try to launch WiCD, I get the message:

    Could not connect to wicd’s D-Bus interface. Check the wicd log for error messages.Could not connect to wicd’s D-Bus interface. Check the wicd log for error messages.

    The log (/var/log/wicd/wicd.log) is empty.

    Help solving this would be appreciated as I am not able to connect to a wireless network.

  • #19028

    Silvan
    Keymaster

    If it worked before try removing the file /etc/wicd/wired-settings.conf. If it never worked, which version of openmamba are you using?

  • #19029

    Piki
    Member

    Thanks for the quick reply.

    It worked before on the LiveCD, so I removed the file you said, and it loads fine now, but when trying to connect to my network with the correct WPA2 Pre-shared Key, it fails to obtain an IP every time. I am using OpenMamba Milestone 1 v1.1.

    EDIT: So far, I’ve tried rebooting without my ethernet connected.

  • #19031

    ercolinux
    Participant

    Hi, try to change the settings of the dhcp in the preferences of wicd, external program tab from automatic to dhcpcd or dhclient.

  • #19036

    Silvan
    Keymaster

    First you need to install dhcpcd in milestone 1.1, before trying what Ercole suggests.

You must be logged in to reply to this topic.