Calamares bugs, may be related to KDE

Home Page Forums users Calamares bugs, may be related to KDE

Tagged: 

This topic contains 3 replies, has 2 voices, and was last updated by  Silvan 2 years, 1 month ago.

  • Author
    Posts
  • #28710

    fusion809
    Participant

    Hi,

    I have just downloaded the openmamba ISO for the first time (never used this OS before now) and I booted the live ISO in a virtual machine (run using VirtualBox 5.0.2), the booting happened with issue, but when I ran the installer, Calamares, I noticed several bugs. For one, when I tried to select my language there was a graphical bug that meant that where the Calamares window and the language drop-down menu intersected the menu was made invisible (see this screenshot, for example). Secondly and most significantly, when I got to the stage of pressing “Install Now” in the popup window (see this screenshot, if you are unsure about what I mean), Calamares crashed. Now, so that I can provide you’s with detailed debugging information, I ran sudo calamares from Konsole and it gave the following output:

    
    13:21:39 [1]: Calamares version: 1.1.2 
    Translation: Calamares: Using system locale: "en_US"
    Translation: Qt: Using default locale, system locale one not found: "en_US"
    13:21:39 [1]: Default font ===== 
    Pixel size:    -1 
    Point size:    9 
    Point sizeF:   9 
    Font family:   "Sans Serif" 
    Metric height: 14 
    13:21:39 [1]: Font height: 14 
    13:21:39 [1]: Available languages: ("ar", "ast", "ca", "cs_CZ", "da", "de", "en", "en_GB", "es_MX", "es", "fi_FI", "fr", "hr", "hu", "id", "it_IT", "ja", "lt", "nl", "pl", "pt_BR", "pt_PT", "ro", "ru", "sk", "sl", "sv", "th", "tr_TR", "zh_CN", "zh_TW") 
    13:21:39 [1]: CalamaresApplication thread: 0x20d8e20 
    13:21:39 [1]: Using Calamares settings file at "/etc/calamares/settings.conf" 
    13:21:39 [1]: Using Calamares branding file at "/etc/calamares/branding/openmamba/branding.desc" 
    13:21:39 [1]: WARNING: the selected branding component does not ship translations. 
    13:21:39 [1]: Loaded branding component "openmamba" 
    13:21:39 [1]: Loading module.desc for "bootloader" 
    13:21:39 [1]: Loading module.desc for "displaymanager" 
    13:21:39 [1]: Loading module.desc for "dracut" 
    13:21:39 [1]: Loading module.desc for "dummyprocess" 
    13:21:39 [1]: Loading module.desc for "dummypython" 
    13:21:39 [1]: Loading module.desc for "finished" 
    13:21:39 [1]: Loading module.desc for "fstab" 
    13:21:39 [1]: Loading module.desc for "grubcfg" 
    13:21:39 [1]: Loading module.desc for "hwclock" 
    13:21:39 [1]: Loading module.desc for "initcpio" 
    13:21:39 [1]: Loading module.desc for "initcpiocfg" 
    13:21:39 [1]: Loading module.desc for "initramfs" 
    13:21:39 [1]: Loading module.desc for "keyboard" 
    13:21:39 [1]: Loading module.desc for "locale" 
    13:21:39 [1]: Loading module.desc for "localecfg" 
    13:21:39 [1]: Loading module.desc for "machineid" 
    13:21:39 [1]: Loading module.desc for "mount" 
    13:21:39 [1]: Loading module.desc for "networkcfg" 
    13:21:39 [1]: Loading module.desc for "openmamba-postinstall" 
    13:21:39 [1]: Loading module.desc for "packages" 
    13:21:39 [1]: Loading module.desc for "partition" 
    13:21:39 [1]: Loading module.desc for "removeuser" 
    13:21:39 [1]: Loading module.desc for "services" 
    13:21:39 [1]: Loading module.desc for "summary" 
    13:21:39 [1]: Loading module.desc for "umount" 
    13:21:39 [1]: Loading module.desc for "unpackfs" 
    13:21:39 [1]: Loading module.desc for "users" 
    13:21:39 [1]: Loading module.desc for "welcome" 
    13:21:39 [1]: Proposed window size: 1010 520 
    13:21:39 [1]: QML import paths: ("/usr/share/calamares/qml", "/usr/bin", "/usr/lib64/qt5/qml") 
    13:21:39 [1]: Initial locale  "en_US" 
    No layout variant specified on the command line
    Trailing -variant option ignored
    13:21:39 [1]: xkbmap selection changed to:  "us" - "" 
    libGL error: pci id for fd 12: 80ee:beef, driver (null)
    OpenGL Warning: glFlushVertexArrayRangeNV not found in mesa table
    OpenGL Warning: glVertexArrayRangeNV not found in mesa table
    OpenGL Warning: glCombinerInputNV not found in mesa table
    OpenGL Warning: glCombinerOutputNV not found in mesa table
    OpenGL Warning: glCombinerParameterfNV not found in mesa table
    OpenGL Warning: glCombinerParameterfvNV not found in mesa table
    OpenGL Warning: glCombinerParameteriNV not found in mesa table
    OpenGL Warning: glCombinerParameterivNV not found in mesa table
    OpenGL Warning: glFinalCombinerInputNV not found in mesa table
    OpenGL Warning: glGetCombinerInputParameterfvNV not found in mesa table
    OpenGL Warning: glGetCombinerInputParameterivNV not found in mesa table
    OpenGL Warning: glGetCombinerOutputParameterfvNV not found in mesa table
    OpenGL Warning: glGetCombinerOutputParameterivNV not found in mesa table
    OpenGL Warning: glGetFinalCombinerInputParameterfvNV not found in mesa table
    OpenGL Warning: glGetFinalCombinerInputParameterivNV not found in mesa table
    OpenGL Warning: glDeleteFencesNV not found in mesa table
    OpenGL Warning: glFinishFenceNV not found in mesa table
    OpenGL Warning: glGenFencesNV not found in mesa table
    OpenGL Warning: glGetFenceivNV not found in mesa table
    OpenGL Warning: glIsFenceNV not found in mesa table
    OpenGL Warning: glSetFenceNV not found in mesa table
    OpenGL Warning: glTestFenceNV not found in mesa table
    libGL error: core dri or dri2 extension not found
    libGL error: failed to load driver: vboxvideo
    OpenGL Warning: XGetVisualInfo returned 0 visuals for 0000000002894480
    OpenGL Warning: Retry with 0x8002 returned 0 visuals
    OpenGL Warning: XGetVisualInfo returned 0 visuals for 0000000002894480
    OpenGL Warning: Retry with 0x8002 returned 0 visuals
    OpenGL Warning: glXGetFBConfigAttrib for 0000000002894480, failed to get XVisualInfo
    OpenGL Warning: XGetVisualInfo returned 0 visuals for 0000000002894480
    OpenGL Warning: Retry with 0x8002 returned 0 visuals
    OpenGL Warning: glXGetFBConfigAttrib for 0000000002894480, failed to get XVisualInfo
    OpenGL Warning: XGetVisualInfo returned 0 visuals for 0000000002894480
    OpenGL Warning: Retry with 0x8002 returned 0 visuals
    OpenGL Warning: glXGetFBConfigAttrib for 0000000002894480, failed to get XVisualInfo
    OpenGL Warning: XGetVisualInfo returned 0 visuals for 0000000002894480
    OpenGL Warning: Retry with 0x8002 returned 0 visuals
    OpenGL Warning: glXGetFBConfigAttrib for 0000000002894480, failed to get XVisualInfo
    OpenGL Warning: XGetVisualInfo returned 0 visuals for 0000000002894480
    OpenGL Warning: Retry with 0x8002 returned 0 visuals
    OpenGL Warning: glXGetFBConfigAttrib for 0000000002894480, failed to get XVisualInfo
    OpenGL Warning: XGetVisualInfo returned 0 visuals for 0000000002894480
    OpenGL Warning: Retry with 0x8002 returned 0 visuals
    OpenGL Warning: glXGetFBConfigAttrib for 0000000002894480, failed to get XVisualInfo
    OpenGL Warning: XGetVisualInfo returned 0 visuals for 0000000002894480
    OpenGL Warning: Retry with 0x8002 returned 0 visuals
    OpenGL Warning: glXGetFBConfigAttrib for 0000000002894480, failed to get XVisualInfo
    OpenGL Warning: XGetVisualInfo returned 0 visuals for 0000000002894480
    OpenGL Warning: Retry with 0x8002 returned 0 visuals
    OpenGL Warning: glXGetFBConfigAttrib for 0000000002894480, failed to get XVisualInfo
    13:21:40 [1]: Cannot open file "/etc/locale.gen" . Assuming the supported languages are already built into the locale archive. 
    13:21:40 [1]: Need at least storage bytes: 5368709120 
    13:21:40 [1]: Need at least ram bytes: 536870912 
    13:21:40 [1]: A battery exists, checking for mains power. 
    13:21:40 [1]: enoughStorage, enoughRam, hasPower, hasInternet, isRoot:  true true true false true 
    13:21:40 [1]: "Osprober lines, clean:
    " 
    13:21:46 [1]: Selected locale "en_GB" 
    13:21:53 [1]: Choice applied:  2 
    13:21:54 [1]: CreatePartitionTableJob::createTable trying to make table for device "/dev/sda" 
    13:21:54 [1]: Updating partitioning preview widgets. 
    13:21:54 [0]: QCoreApplication::postEvent: Unexpected null receiver
    13:21:55 [1]: Suggested swap size: 8.50443 GiB 
    13:21:55 [1]: Updating partitioning preview widgets. 
    13:21:55 [0]: QCoreApplication::postEvent: Unexpected null receiver
    13:21:55 [1]: # Queue: 
    13:21:55 [1]: ## Device: "ATA VBOX HARDDISK" 
    13:21:55 [1]: - "Create new msdos partition table on /dev/sda." 
    13:21:55 [1]: - "Create new 25702MB partition on /dev/sda (ATA VBOX HARDDISK) with file system ext4." 
    13:21:55 [1]: - "Create new 8708MB partition on /dev/sda (ATA VBOX HARDDISK) with file system linuxswap." 
    13:21:55 [1]: - "Create new 227726MB partition on /dev/sda (ATA VBOX HARDDISK) with file system ext4." 
    13:22:15 [0]: QLayout: Attempting to add QLayout "" to QWidget "", which already has a layout
    13:22:15 [1]: PartitionCodeModule has been asked for jobs. About to return: "Clear all temporary mounts.
    Clear mounts for partitioning operations on /dev/sda
    Create new msdos partition table on /dev/sda.
    Create new 25702MB partition on /dev/sda (ATA VBOX HARDDISK) with file system ext4.
    Create new 8708MB partition on /dev/sda (ATA VBOX HARDDISK) with file system linuxswap.
    Create new 227726MB partition on /dev/sda (ATA VBOX HARDDISK) with file system ext4.
    Set partition information" 
    13:22:15 [1]: Gathering UUIDs for partitions that exist now. 
    13:22:15 [1]: QHash(("", "")) 
    13:22:15 [1]: Writing to GlobalStorage["partitions"] 
    13:22:15 [1]: "" mtpoint: "/" fs: "ext4" "" 
    13:22:15 [1]: "" mtpoint: "" fs: "linuxswap" "" 
    13:22:15 [1]: "" mtpoint: "" fs: "ext4" "" 
    13:22:15 [1]: Gathering UUIDs for partitions that exist now. 
    13:22:15 [1]: QHash(("", "")) 
    13:22:15 [1]: Writing to GlobalStorage["partitions"] 
    13:22:15 [1]: "" mtpoint: "/" fs: "ext4" "" 
    13:22:15 [1]: "" mtpoint: "" fs: "linuxswap" "" 
    13:22:15 [1]: "" mtpoint: "" fs: "ext4" "" 
    OpenGL Warning: glXCreatePbuffer not implemented by Chromium
    OpenGL Warning: glXCreatePbuffer not implemented by Chromium
    

    Now the reason why I said “may be related to KDE” in the title is that I know that Calamares also has issues (not quite the same, but still related to graphics) in Sabayon KDE edition, see this post on the Sabayon forums for details.

    • This topic was modified 2 years, 1 month ago by  fusion809.
  • #28712

    Silvan
    Keymaster

    Thanks for reporting the problems with details to help us fix them.
    Calamares was recently updated in openmamba but I could not do extensive tests so far.
    About the most importat problem, did you choose automatic partitioning of the whole disk? This is a function I have patched for openmamba and which needs more testing, because I suspect wrongly calculated partitions might cause the crash. So if this is the case I would suggest you to try with manual partitiong and see if it works, as I haven’t patched anything there.

    • This reply was modified 2 years, 1 month ago by  Silvan.
  • #28714

    fusion809
    Participant

    I was using automatic partitioning, but I just tried manual (MBR, single 256 GB ext2 partition, if relevant) partitioning and it resulted in the same crash.

  • #28715

    Silvan
    Keymaster

    Hi,
    I’ve just tried installing openmamba-milestone3-livecd-it-snapshot-20150908 on both libvirt and VirtualBox virtual machines and could not repoduce the problem.
    In your log, for some yet unknown reason, device are not gathered after repartitioning and the QHash returned is empty:

    13:22:15 [1]: Gathering UUIDs for partitions that exist now. 
    13:22:15 [1]: QHash(("", "")) 

    as a workaround, did you try installing on a partition that already exist, i.e. without telling Calamares to change any partition?

You must be logged in to reply to this topic.