PlayOnLinux: problemi wine 32

Home Page Forum utenti PlayOnLinux: problemi wine 32

  • Questo topic ha 11 risposte, 2 partecipanti ed è stato aggiornato l'ultima volta 3 anni fa da bottye.
Visualizzazione 11 filoni di risposte
  • Autore
    Articoli
    • #32579
      bottye
      Partecipante

      Ciao,

      lanciando POL (Play on Linux) o Q4Wine non mi viene rilevato wine

      L’errore fornito da Q4Wine è:

      Cannot find or execute the ‘wine’ binary. Make sure that this binary is available by search PATH variable and see also INSTALL file for application depends.

      Come posso risolvere?

      Grazie
      E-

    • #32583
      Silvan
      Amministratore del forum

      Ciao,
      prova con:

      sudo yum install wine.i586

    • #32584
      bottye
      Partecipante

      Ciao.

      Lo ha installato ma pare non funzioni comunque, stesso errore. [POL, dice che mancano anche le OpenGL]

      Lo strano è che lanciando Mine da Q4Wine o da menù OM [Avviatore|Applicazioni|Wine|Mine]
      funziona ma non si può installa nulla.
      Pare venga cercato wine e trovato wine64…

      Grazie
      E-

    • #32585
      Silvan
      Amministratore del forum

      Ciao,
      il comando fornito serve per installare l’eseguibile wine. Se il comando è andato a buon fine l’eseguibile deve essere disponibile (prova ad eseguire il comando wine da un terminale). Se il comando non fosse presente occorre innanzitutto verificare bene l’esito del comando che ho fornito per installarlo.

      Invece, se l’errore precedente era sull’eseguibile wine mentre l’attuale è sulle OpenGL, ovvero non si tratta dello “stesso errore”, si può trattare di verificare o installare il pacchetto libGL-Mesa-dri-18.0.3-1mamba.i586 e controllare che esista il link /usr/lib/libGL.so.1.

      • Questa risposta è stata modificata 3 anni, 5 mesi fa da Silvan.
      • Questa risposta è stata modificata 3 anni, 1 mese fa da Silvan.
      • Questa risposta è stata modificata 3 anni fa da Silvan.
    • #32661
      bottye
      Partecipante

      Ciao,
      per risolvere l’errore n1 in PlayOnLinux ho trovato questo, può servire?

      PlayOnLinux non è in grado di trovare le librerie a 32bit di OpenGL Forse si riscontreranno problemi con i giochi

      Per il n2:
      PlayOnLinux cannot find wine (from Wine) You should install it to use PlayOnLinux

      sudo yum install wine.i586

      dice sempre Niente da fare
      +/- idem con update

      Grazie
      E-

    • #32666
      Silvan
      Amministratore del forum

      Ciao,
      per completare/verificare l’installazione di Wine a 32 bit il comando da eseguire è

      sudo yum install wine-core.i586

      Se il comando fornisce errori è utile riportare qui il copia/incolla integrale dei messaggi che compaiono sul terminale.

      Se il comando dice che è già installato, allora puoi eseguire:

      wine --check-libs

      dopodiché se manca la libGL.so.1 (a 32 bit):

      sudo yum intall libGL-Mesa-dri.i586

      se manca altro o se riscontri errori a qualunque punto di questa procedura procediamo dopo la tua risposta per arrivare alla soluzione.

    • #32677
      bottye
      Partecipante

      Ciao, questo l’errore proprio al primo comando :

      sudo yum install wine-core.i586

      non ho copiato tutta la lista dei file prima, è lunghissima,,, ed e troncata la prima parte a video, come non stesse nel buffer; non so come mandarlo in un file.
      [tra l’altro spegnendo konsole è andata in bomba o in crash, se preferisci…]


      libutil.so.1()(64bit) is needed by (installed) vim-8.1.0374-1mamba.x86_64
      libutil.so.1()(64bit) is needed by (installed) sudo-1.8.25-1mamba.x86_64
      libutil.so.1()(64bit) is needed by (installed) libldb-1.3.6-2mamba.x86_64
      libutil.so.1(GLIBC_2.2.5)(64bit) is needed by (installed) libxen-4.8.0-1mamba.x86_64
      libutil.so.1(GLIBC_2.2.5)(64bit) is needed by (installed) libgnome-vfs-2.24.4-4mamba.x86_64
      libutil.so.1(GLIBC_2.2.5)(64bit) is needed by (installed) ruby18-1.8.7.p374-1mamba.x86_64
      libutil.so.1(GLIBC_2.2.5)(64bit) is needed by (installed) ppp-2.4.7-1mamba.x86_64

      Riportare questo errore su http://yum.baseurl.org/report
      ** Trovati 10 problemi pre-esistenti nel rpmdb, l’output di ‘yum check’ è:
      alsa-utils-1.1.6-1mamba.x86_64 è un duplicato di alsa-utils-1.1.5-1mamba.x86_64
      alsa-utils-midi-1.1.6-1mamba.x86_64 è un duplicato di alsa-utils-midi-1.1.5-1mamba.x86_64
      gutenprint-5.2.14-1mamba.x86_64 è un duplicato di gutenprint-5.2.13-1mamba.x86_64
      libalsa-1.1.6-1mamba.x86_64 è un duplicato di libalsa-1.1.5-1mamba.x86_64
      libalsa-plugins-1.1.6-1mamba.x86_64 è un duplicato di libalsa-plugins-1.1.5-1mamba.x86_64
      libgcj4-6.4.0-3mamba.x86_64 è un duplicato di libgcj4-6.2.0-1mamba.x86_64
      libmwaw-0.3.14-1mamba.x86_64 è un duplicato di libmwaw-0.3.13-1mamba.x86_64
      libvpx-1.7.0-1mamba.x86_64 è un duplicato di libvpx-1.6.1-1mamba.x86_64
      openvpn-2.4.6-1mamba.x86_64 è un duplicato di openvpn-2.4.5-1mamba.x86_64
      ttf-symbola-11.00-1mamba.x86_64 è un duplicato di ttf-symbola-10.24-1mamba.x86_64
      Your transaction was saved, rerun it with: yum load-transaction /tmp/yum_save_tx-2018-09-20-21-25D9A5JB.yumtx

      dando:
      wine --check-libs

      ottengo:

      bash: wine: comando non trovato…

      Grazie e buona giornata!

      E-

    • #32706
      Silvan
      Amministratore del forum

      Ciao,
      per la procedura aggiornata per installare Wine vedi questo commento in un’altra discussione sullo stesso argomento.

    • #32708
      bottye
      Partecipante

      Ciao,

      ho provato la procedura indicata ma riscontro ancora errori e in POL non vedo differenze [stessi errori] 🙁

      [bottye@BEAM_PC ~]$ sudo yum update
      Password:
      Plugin abilitati:refresh-packagekit
      Impostazione processo di aggiornamento
      Nessun pacchetto marcato per l’aggiornamento

      [bottye@BEAM_PC ~]$ sudo yum install wine wine-core.i586
      Plugin abilitati:refresh-packagekit
      Impostazione processo di installazione
      Risoluzione dipendenze
      –> Esecuzione del controllo di transazione
      .
      .
      .
      Riepilogo della transazione
      ===============================================================================================================================================================================================================================================================================
      Install 211 Packages

      Dimensione totale: 228 M
      Dimensione installata: 228 M
      Procedere : s
      Download dei pacchetti:
      Running Transaction Check
      Test di transazione in corso

      Errore nel controllo transazione:
      package libxcb-1.13.1-1mamba.x86_64 (which is newer than libxcb-1.13-1mamba.i586) is already installed
      file /usr/share/alsa/cards/USB-Audio.conf from install of libalsa-1.1.6-1mamba.i586 conflicts with file from package libalsa-1.1.5-1mamba.x86_64

      Riepilogo errori
      —————-

      sudo yum install libxslt.i586 libGL-Mesa-dri.i586 libva.i586 libcairo.i586 libcapi20.i586 libv4l.i586 libsane-backends.i586 libnetapi.i586 libodbc.i586 libpng.i586 libOSMesa.i586 libgnome-keyring.i586
      Plugin abilitati:refresh-packagekit
      Impostazione processo di installazione
      Risoluzione dipendenze
      –> Esecuzione del controllo di transazione
      .
      .
      .
      Riepilogo della transazione
      ===============================================================================================================================================================================================================================================================================
      Install 155 Packages

      Dimensione totale: 169 M
      Dimensione installata: 169 M
      Procedere : s
      Download dei pacchetti:
      Running Transaction Check
      Test di transazione in corso

      Errore nel controllo transazione:
      package libxcb-1.13.1-1mamba.x86_64 (which is newer than libxcb-1.13-1mamba.i586) is already installed

      Riepilogo errori
      —————-

      Ho provato a disinstallare POL con Apper e mi ha dato il seguente errore:

      Error Type: <class 'yum.Errors.NoMoreMirrorsRepoError'><br>Error Value: failure: repodata/403655b01664ec214ec5c702e21f894556c8739db8c6cc41ecd48fd5f43e5527-filelists.sqlite.bz2 from rolling: [Errno 256] No more mirrors to try.<br> File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3532, in <module><br> main()<br> File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3529, in main<br> backend.dispatcher(sys.argv[1:])<br> File : /usr/lib/python2.7/site-packages/packagekit/backend.py, line 740, in dispatcher<br> self.dispatch_command(args[0], args[1:])<br> File : /usr/lib/python2.7/site-packages/packagekit/backend.py, line 604, in dispatch_command<br> self.get_files(package_ids)<br> File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2546, in get_files<br> files = pkg.returnFileEntries('dir')<br> File : /usr/lib/python2.7/site-packages/yum/sqlitesack.py, line 361, in returnFileEntries<br> self._loadFiles()<br> File : /usr/lib/python2.7/site-packages/yum/sqlitesack.py, line 294, in _loadFiles<br> self.sack.populate(self.repo, mdtype='filelists')<br> File : /usr/lib/python2.7/site-packages/yum/yumRepo.py, line 172, in populate<br> db_fn = repo._retrieveMD(mydbtype)<br> File : /usr/lib/python2.7/site-packages/yum/yumRepo.py, line 1616, in _retrieveMD<br> size=thisdata.size)<br> File : /usr/lib/python2.7/site-packages/yum/yumRepo.py, line 843, in _getFile<br> raise Errors.NoMoreMirrorsRepoError, errstr<br>

      Grazie

      E-

    • #32709
      bottye
      Partecipante

      Ho provato a disinstallare e reinstallare POL…

    • #32710
      Silvan
      Amministratore del forum

      Ciao,
      gli errori riguardanti libxcb non dovrebbero più presentarsi.
      Per l’errore su libalsa, forse hai installate sia le versioni 1.1.5 che 1.1.6 per x86_64, lo verificherei con:

      rpm -q libalsa

      se è così occorre rimuovere manualmente la versione più vecchia:

      sudo rpm -e libalsa-1.1.5-1mamba.x86_64

      Ovviamente l’installazione di wine deve andare a buon fine prima di fare altri tentativi con playonlinux. Comunque sul sistema in cui ho installato wine.i586 mi risulta partire ed eseguire correttamente l’applicazione che ho preinstallata, Microsoft Paint.

    • #32711
      bottye
      Partecipante

      Ciao,

      avevi ragione c’erano 2 alsa..
      ora funziona tutto facendo:

      sudo rpm -e libalsa-1.1.5-1mamba.x86_64

      sudo yum update

      sudo yum install wine wine-core.i586

      sudo yum install libxslt.i586 libGL-Mesa-dri.i586 libva.i586 libcairo.i586 libcapi20.i586 libv4l.i586 libsane-backends.i586 libnetapi.i586 libodbc.i586 libpng.i586 libOSMesa.i586 libgnome-keyring.i586

      🙂 Grazie!!!
      E-

Visualizzazione 11 filoni di risposte
  • Devi aver eseguito l’accesso per poter rispondere a questa discussione.