Wireless USB

Home Page Forum utenti Wireless USB

Questo argomento contiene 8 risposte, ha 3 partecipanti, ed è stato aggiornato da  hackerberry 12 anni, 1 mese fa.

  • Autore
    Articoli
  • #17574

    hackerberry
    Membro

    Salve, dovrei configurare una semplice rete wireless tra il mio computer con openmamba linux e l’access point che ho a casa.

    La penna che utlizzo usa i driver zydas zd1211rw che mi sembrano corettamente installati se installo la distro con la penna inserita, siccome però è la prima volta che configuro una rete in linux, come faccio ad impostare i parametri tra cui anche la chiave WPA?

    Grazie in anticipo…

  • #22787

    Silvan
    Amministratore del forum

    Ciao,

    l’autenticazione WPA non è al momento disponibile, devi configurare l’access point per usare WEP.

    Pagina del wiki.

    Silvan

  • #22793

    hackerberry
    Membro

    Sarò io scemo, ma non riesco a farla nadare, posto alcuni comandi e relativo output:

    [root@openmamba hackerberry]# iwconfig

    lo no wireless extensions.

    eth0 no wireless extensions.

    eth1 IEEE 802.11b/g ESSID:”linksys” Nickname:”zd1211″

    Mode:Managed Access Point: Invalid

    Encryption key:off

    Link Quality:0 Signal level:0 Noise level:0

    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0

    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    [root@openmamba hackerberry]# route -n

    Kernel IP routing table

    Destination Gateway Genmask Flags Metric Ref Use Iface

    [root@openmamba hackerberry]# ifconfig -a

    eth0 Link encap:Ethernet HWaddr 00:19:66:41:48:BE

    UP BROADCAST MULTICAST MTU:1500 Metric:1

    RX packets:0 errors:0 dropped:0 overruns:0 frame:0

    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

    collisions:0 txqueuelen:1000

    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    Interrupt:16 Base address:0x2000

    eth1 Link encap:Ethernet HWaddr 00:13:F7:A9:81:60

    inet addr:192.168.1.105 Bcast:192.168.1.255 Mask:255.255.255.0

    BROADCAST MULTICAST MTU:1500 Metric:1

    RX packets:0 errors:0 dropped:0 overruns:0 frame:0

    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

    collisions:0 txqueuelen:1000

    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    lo Link encap:Local Loopback

    inet addr:127.0.0.1 Mask:255.0.0.0

    inet6 addr: ::1/128 Scope:Host

    UP LOOPBACK RUNNING MTU:16436 Metric:1

    RX packets:196 errors:0 dropped:0 overruns:0 frame:0

    TX packets:196 errors:0 dropped:0 overruns:0 carrier:0

    collisions:0 txqueuelen:0

    RX bytes:15134 (14.7 Kb) TX bytes:15134 (14.7 Kb)

    E’ normale che sia rilevata in eth1?

  • #22794

    fabiog
    Partecipante

    si anche a me vede la wlan come eth1 con openmamba con kubuntu invece era qualcosa di totalmente diverso una cosa tipo rd0 se non sbaglio!

    Verifica prima la rete senza wep o wpa così verifichi l’hardware e/o prova a dare il comando:

    iwconfig eth1 ap auto

  • #22795

    hackerberry
    Membro

    Wep e Wpa sono disattivate adesso sono senza chiavi.

    Il comando che mi hai dato fa scena muta cioè non da niente in output e ci mette un millesimo di secondo ad eseguirsi.

    E se poi ridò “iwconfig” ritorna senmpre la stessa cosa di prima.

  • #22798

    Silvan
    Amministratore del forum

    Guarda se in /var/log/dmesg.log oppure nell’output del comando dmesg oppure in /var/log/messages compare qualche messaggio relativo a questo driver (tipo firmware mancante o altri errori).

  • #22799

    hackerberry
    Membro

    L’output di dmesg:

    Adding 979924k swap on /dev/hda6. Priority:1 extents:1 across:979924k

    usb 1-3: Could not load firmware file zd1211/zd1211b_ub. Error number -2

    zd1211rw 1-3:1.0: couldn’t load firmware. Error number -2

    usb 1-3: Could not load firmware file zd1211/zd1211b_ub. Error number -2

    zd1211rw 1-3:1.0: couldn’t load firmware. Error number -2

    eth0: no link during initialization.

    Comunque ho scaricato il pacchetto del firmware 1.4 dal sito:

    http://sourceforge.net/project/showfiles.php?group_id=129083&package_id=187875

    E installato scomattando la cartella il /lib/firmware/zd1211

    Mi son dimenticato qualcosa?

  • #22800

    Silvan
    Amministratore del forum

    Il firmware è distribuibile, per cui ho creato il pacchetto con nome zd1211-firmware e sarà nei prossimi livecd. L’installazione che hai fatto sembra essere corretta, magari la versione 1.4 del firmware richiede il driver incluso nel kernel 2.6.24? (per saperlo prova con la versione 1.3).

  • #22801

    hackerberry
    Membro

    Bastava riavviare…

    Dopo aver installato il firmware 1.4 bastava riavviare e adesso va alla grande, grazie e scusate le gaffes…

Devi essere loggato per rispondere a questa discussione.