Vlc

Home Page Forum utenti Vlc

Visualizzazione 8 filoni di risposte
  • Autore
    Articoli
    • #32721
      lillo
      Partecipante

      Sono appena passato ad un i7 3770 su cui ho installato OM rolling
      Piano piano vado a conoscerlo

      Primo problemino è che VLC non si apre
      ho già provato a rimuoverlo e reinstallarlo ma niente!

      Potete soccorrermi ?

    • #32722
      ercolinux
      Moderatore

      Non ti da nessun errore all’avvio del programma?
      Puoi provare a lanciarlo in un terminale e postare l’output che ti da?

    • #32723
      lillo
      Partecipante

      Scusa ma sono un po’ incapace:
      su terminale ho digitato vlc e dato invio (spero sia giusto) con questo risultato

      VLC media player 2.2.8 Weatherwax (revision 2.2.7-14-g3cc1d8cba9)
      [0000000000a35b58] core libvlc: Esecuzione di vlc con l’interfaccia predefinita. Usa ‘cvlc’ per utilizzare vlc senza interfaccia.
      Errore di segmentazione (core dump creato)

      se potrai aiutarmi, sappi che sono molto molto scarso.

    • #32724
      lillo
      Partecipante

      Visto che vlc non andava mi sono scaricato Amarok da gestione software:
      non va neanche lui e da terminale

      [utente@utente-pc ~]$ amarok
      amarok: relocation error: /usr/lib64/libavcodec.so.57: symbol avpriv_vga16_font version LIBAVUTIL_55 not defined in file libavutil.so.55 with link time reference

      non sono sicuro ma forse quando alle prime accensioni ho istallato i componenti di base OM e gli altri che suggerisce, non è riuscito ad istallare tutto. boh !

    • #32725
      Silvan
      Amministratore del forum

      Ciao,
      il problema è quasi certamente causato dal fatto che dopo un recente aggiornamento di ffmpeg la libreria libavcodec.so.57 è fornita dal pacchetto libavcodec-libav anziché da libavcodec-ffmpeg3 (ed eventualmente la situazione è la stessa per altre librerie libav*).

      Sto procedendo ad un aggiornamento di ffmpeg per rendere obsoleto libav e possibilmente risolvere il problema con un normale aggiornamento di sistema.

      Intanto è possibile forzare la correzione con i seguenti comandi da terminale:

      sudo rpm -e libavcodec-libav --nodeps
      sudo yum install libavcodec-ffmpeg3

      Maggiori informazioni in merito al dualismo ffmpeg/libav si trovano qui.

      • Questa risposta è stata modificata 2 anni, 10 mesi fa da Silvan.
    • #32727
      lillo
      Partecipante

      Ciao
      dando i comandi suggeriti non è cambiato nulla.
      Anche dei giochi non vanno o si chiudono all’improvviso.
      Anche Cromium a volte fatica ad avviarsi.
      LibreOffice è in cinese o chissà che lingua.

      è forse andato storto qualcosa nell’istallazione?

    • #32728
      Silvan
      Amministratore del forum

      Ciao,
      per quanto riguarda VLC il suggerimento è di effettuare un aggiornamento di sistema con il comando da terminale:
      sudo yum update

      Per dei giochi che hanno problemi, questi andrebbero valutati caso per caso.

      Per quanto riguarda chromium che, a volte, fatica ad avviarsi, la versione attuale in rolling è un po’ vecchia e si può aggiornare con:
      sudo yum install chromium --enablerepo=unstable-makedist

      Per quanto riguarda libreoffice, molto probabilmente manca il pacchetto per la lingua italiana, che si può installare con il comando da terminale:
      sudo yum install libreoffice-i18n-it

    • #32729
      lillo
      Partecipante

      Ciao,
      dopo quel mega aggiornamento che avevi mandato, Vlc funziona.
      Ho comunque aggiornato da terminale:
      E’ giusto che dica così ?

      [utente@utente-pc ~]$ sudo yum update
      Password:
      Plugin abilitati:refresh-packagekit
      Impostazione processo di aggiornamento
      Risoluzione dipendenze
      –> Esecuzione del controllo di transazione
      —> Package groff.x86_64 0:1.22.3-2mamba will be aggiornato
      —> Package groff.x86_64 0:1.22.4-1mamba will be an update
      —> Package libappstream.x86_64 0:0.12.3-1mamba will be aggiornato
      —> Package libappstream.x86_64 0:0.12.4-1mamba will be an update
      —> Package libappstream-qt.x86_64 0:0.12.3-1mamba will be aggiornato
      —> Package libappstream-qt.x86_64 0:0.12.4-1mamba will be an update
      —> Package libgphoto2.x86_64 1:2.5.20-1mamba will be aggiornato
      —> Package libgphoto2.x86_64 1:2.5.21-1mamba will be an update
      —> Package libgphoto2-common.x86_64 1:2.5.20-1mamba will be aggiornato
      —> Package libgphoto2-common.x86_64 1:2.5.21-1mamba will be an update
      —> Package libharfbuzz.x86_64 0:2.1.3-1mamba will be aggiornato
      —> Package libharfbuzz.x86_64 0:2.2.0-1mamba will be an update
      —> Package libharfbuzz-devel.x86_64 0:2.1.3-1mamba will be aggiornato
      —> Package libharfbuzz-devel.x86_64 0:2.2.0-1mamba will be an update
      —> Package libjansson.x86_64 0:2.11-2mamba will be aggiornato
      —> Package libjansson.x86_64 0:2.12-1mamba will be an update
      —> Package libkconfigwidgets.x86_64 0:5.52.0-1mamba will be aggiornato
      —> Package libkconfigwidgets.x86_64 0:5.53.0-1mamba will be an update
      —> Package libktexteditor.x86_64 0:5.52.0-1mamba will be aggiornato
      —> Package libktexteditor.x86_64 0:5.53.0-1mamba will be an update
      —> Package libplasma-framework.x86_64 0:5.52.0-1mamba will be aggiornato
      —> Package libplasma-framework.x86_64 0:5.53.0-1mamba will be an update
      —> Package libtotem.x86_64 0:3.26.2-1mamba will be aggiornato
      —> Package libtotem.x86_64 0:3.30.0-1mamba will be an update
      —> Package totem-mozilla-plugin.x86_64 0:3.26.2-1mamba will be aggiornato
      —> Package totem-mozilla-plugin.x86_64 0:3.30.0-1mamba will be an update
      —> Package xterm.x86_64 0:337-1mamba will be aggiornato
      —> Package xterm.x86_64 0:340-1mamba will be an update
      –> Risoluzione delle dipendenze completata

      Dipendenze risolte

      ========================================================================================
      Pacchetto Arch Versione Repository Dim.
      ========================================================================================
      Aggiornamento:
      groff x86_64 1.22.4-1mamba rolling 5.8 M
      libappstream x86_64 0.12.4-1mamba rolling 139 k
      libappstream-qt x86_64 0.12.4-1mamba rolling 66 k
      libgphoto2 x86_64 1:2.5.21-1mamba rolling 3.0 M
      libgphoto2-common x86_64 1:2.5.21-1mamba rolling 95 k
      libharfbuzz x86_64 2.2.0-1mamba rolling 473 k
      libharfbuzz-devel x86_64 2.2.0-1mamba rolling 819 k
      libjansson x86_64 2.12-1mamba rolling 30 k
      libkconfigwidgets x86_64 5.53.0-1mamba rolling 446 k
      libktexteditor x86_64 5.53.0-1mamba rolling 4.0 M
      libplasma-framework x86_64 5.53.0-1mamba rolling 941 k
      libtotem x86_64 3.30.0-1mamba rolling 580 k
      totem-mozilla-plugin x86_64 3.30.0-1mamba rolling 2.4 k
      xterm x86_64 340-1mamba rolling 403 k

      Riepilogo della transazione
      ========================================================================================
      Upgrade 14 Packages

      Dimensione totale: 17 M
      Dimensione totale del download: 10 M
      Procedere : s
      Download dei pacchetti:
      (1/9): groff-1.22.4-1mamba.x86_64.rpm | 5.8 MB 00:00:05
      (2/9): libappstream-0.12.4-1mamba.x86_64.rpm | 139 kB 00:00:00
      (3/9): libappstream-qt-0.12.4-1mamba.x86_64.rpm | 66 kB 00:00:00
      (4/9): libgphoto2-2.5.21-1mamba.x86_64.rpm | 3.0 MB 00:00:02
      (5/9): libgphoto2-common-2.5.21-1mamba.x86_64.rpm | 95 kB 00:00:00
      (6/9): libjansson-2.12-1mamba.x86_64.rpm | 30 kB 00:00:00
      (7/9): libtotem-3.30.0-1mamba.x86_64.rpm | 580 kB 00:00:00
      (8/9): totem-mozilla-plugin-3.30.0-1mamba.x86_64.rpm | 2.4 kB 00:00:00
      (9/9): xterm-340-1mamba.x86_64.rpm | 403 kB 00:00:00
      —————————————————————————————-
      Totale 1.0 MB/s | 10 MB 00:09
      Running Transaction Check
      ERROR with transaction check vs depsolve:
      libKF5Parts.so.5()(64bit) is needed by libktexteditor-5.53.0-1mamba.x86_64
      Riportare questo errore su http://yum.baseurl.org/report
      ** Trovati 32 problemi pre-esistenti nel rpmdb, l’output di ‘yum check’ è:
      desktop-base-kde-4.0.4-3mamba.x86_64 ha una dipendenza mancante di kde-gtk-config5
      desktop-base-kde-4.0.4-3mamba.x86_64 ha una dipendenza mancante di kpackage
      dolphin-plugins-18.08.3-1mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      dracut-048-3mamba.x86_64 ha una dipendenza mancante di lvm2
      keditbookmarks-18.08.3-1mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      kfind-18.08.3-1mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      kmenuedit-5.14.4-1mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      konqueror-18.08.3-1mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      konsole-18.08.3-1mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      kwrite-18.08.3-1mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      libcalamares-3.2.2-2mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      libdolphin-18.08.3-1mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      libkdelibs4support-5.53.0-1mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      libkdeplasma-addons-5.14.4-1mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      libkhotkeys-5.14.4-1mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      libkhtml-5.53.0-1mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      libkio-extras-18.08.3-1mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      libkonqueror-18.08.3-1mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      libkross-5.53.0-1mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      libktexteditor-5.52.0-1mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      libokular-18.08.3-1mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      libplasma-desktop-5.14.4-1mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      libplasma-framework-5.52.0-1mamba.x86_64 ha una dipendenza mancante di plasma-framework = (‘0’, ‘5.52.0’, ‘1mamba’)
      libplasma-workspace-5.14.4-1mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      libsolid-5.53.0-1mamba.x86_64 ha una dipendenza mancante di solid = (‘0’, ‘5.53.0’, ‘1mamba’)
      libsystemsettings-5.14.4-1mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      okular-18.08.3-1mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      plasma-desktop-5.14.4-1mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      plasma-framework-5.53.0-1mamba.x86_64 ha una dipendenza mancante di libplasma-framework = (‘0’, ‘5.53.0’, ‘1mamba’)
      plasma-workspace-5.14.4-1mamba.x86_64 ha una dipendenza mancante di discover
      plasma-workspace-5.14.4-1mamba.x86_64 ha una dipendenza mancante di libKF5Parts.so.5()(64bit)
      plasma-workspace-5.14.4-1mamba.x86_64 ha una dipendenza mancante di milou
      Your transaction was saved, rerun it with: yum load-transaction /tmp/yum_save_tx-2018-12-25-15-533pR3JI.yumtx
      [utente@utente-pc ~]$

      Vlc funziona e quindi le mie esigenze sono soddisfatte. Per conoscenza Amarok mi da errore della banca dati.
      Libreoffice dopo le tue istruzioni è in italiano, molto bene!
      Per Cromium ti dirò man mano che lo uso.
      Ti ringrazio molto
      Buon Natale

    • #32731
      Silvan
      Amministratore del forum

      Ciao,
      l’output di yum update che riporti mostra un problema noto che si verifica effettuando l’aggiornamento dal desktop. Vorrei e dovrei risolverlo prima possibile ma non sono ancora riuscito a trovare il momento giusto per occuparmene.

      Nel frattempo il consiglio è di effettuare i prossimi aggiornamenti da terminale con il comando:
      sudo yum update

      Mentre per correggere la situazione in cui si trova la tua installazione bisogna reinstallare i pacchetti a cui corrispondono gli errori, nel tuo caso dovresti eseguire il seguente comando:
      sudo yum install kde-gtk-config5 kpackage libkparts plasma-framework solid discover milou

Visualizzazione 8 filoni di risposte
  • Devi aver eseguito l’accesso per poter rispondere a questa discussione.