Salve! Mi servirebbe qualche info…

Home Page Forum utenti Salve! Mi servirebbe qualche info…

Tag: , ,

  • Questo topic ha 10 risposte, 3 partecipanti ed è stato aggiornato l'ultima volta 8 anni, 5 mesi fa da gigi.
Visualizzazione 10 filoni di risposte
  • Autore
    Articoli
    • #20602
      gigi
      Membro

      Ciao a tutti!

      Mi sono appena registrato e da poco ho finito di installare la versione stabile di mamba.

      Sto cercando una distro che continui a supportare i vecchi driver dri di mesa in particolare io ho bisogno del driver savage.

      La versione che avevo scaricato aveva ancora la versione 7 nella quale questi sono presenti ma avventuradomi nell’aggiornamento alla 8 ora mi trovo con un sistema senza accelerazione.

      Vorrei sapere se posso tornare alla situazione precedente e bloccare l’aggiornamento di questo pacchetto o se è questione di tempo e i vecchi driver saranno ripristinati…

    • #27198
      Silvan
      Amministratore del forum

      Ciao,

      ho messo i driver tratti da Mesa 7 nel pacchetto libGL-Mesa-dri1. Puoi provare ad installare questo pacchetto, riavviare e verificare se questo basta a risolvere il problema?

    • #27203
      gigi
      Membro

      mo vè ho fatto proprio questo!

      ho estratto dal cd live (se non sbaglio milestone2-2.0.10) savage_dri.so e l’ho messo in /usr/lib/dri e funge! glxgears a 140FPS di nuovo.

      attualmente ho xorg 1.10, kernel 3.4.39-1, libGL-Mesa-dri.8.0.4-3.

      Vengo da una amata distro che aveva fatto la stessa cosa ma con gli aggiornamenti poi persi di nuovo l’accelerazione e cio’ non mi va giù.

      mi sembra che questo avviene definitivamente passando xorg 1.12, mesa 9, kernel 3.7…. sicuramente mi sbaglio.

      comunque mi piace mamba, funziona tutto sul mio pc!

      Spero solo che il blocco che ho messo per evitare l’aggiornamento dei pacchetti interessati non mi dia troppi problemi!

      A proposito: sto cercando di ricreare il gruppo di programmi che uso ma alcuni mancano dai repo di default: cosa succede se mixo delle sorgenti debian apt?

      (scusa la domanda ma non ho ancora esplorato i docs; sono già contento di avere un sistema efficente…)

    • #27204
      ercolinux
      Moderatore

      Se ci sono programmi che ti mancano prova a chiedere: compatibilmente con la disponibilità di tempo, cercheremo di pacchettizzarli.

      Installare pacchetti di altre distro potrebbe funzionare ma non si garantisce il risultato

    • #27205
      gigi
      Membro

      ok installato e funziona; mantenuto versione 8.

      Vorrei usare nomacs che ha un rpm per fedora o il sorgente; in questo caso sarebbe utile checkinstall per una gestione centralizzata…

      mi piacerebbe anche smplayer2 e DEVO installare claws-mail.

      Ps: sono nuovo al mondo rpm e mi chiedevo se esiste una gui ncurses con i comandi fondamentali…

    • #27207
      Silvan
      Amministratore del forum

      Ok grazie, integrerò i driver legacy in tutte le installazioni milestone2. Su devel saranno anche da testare visto che mi pare che segnali che con Xorg 1.12 e Mesa 9 su un’altra distro non funzionavano, bisognerà capire se si tratta solo di un problema di pacchettizzazione oppure se è un’imcompatibilità non risolvibile con i sistemi più aggiornati.

      claws-mail è stato fatto oggi da ercolinux e me e sarà disponibile entro qualche ora sulla versione stabile.

      Faremo anche nomacs e smplayer2. Come immaginerai i suggerimenti sono ben accetti così ne approfittiamo sia per rendere la distribuzione più completa che per avere un feedback circa il corretto funzionamento dei nuovi pacchetti.

    • #27211
      gigi
      Membro

      molte grazie!

      al tempo del problema mi documentai e scoprii che dalla versione 1.14 le interfacce delle api dei driver di xorg-mesa sono state cambiate e che i driver più vecchi non venivano adeguati. nel driver savage diventa impossibile usare xaa perdendo dri e aixgl; per un pò mi è funzionata la modaltà exa ma poi qualcosa deve essere cambiato anche nel kernel che non caricava savage e drm e dovevo farlo a mano; poi nulla, solo modo vesa.

      Credo che le app che hanno bisogno della nuova implementazione siano veramente poche e scegliere di creare una dipendenza da una particolare versione del sistema grafico sia da limitare a queste, se possibile.

      Se avete bisogno di testare qualcosa sono disponibile; una cosa che personalmente non mi piace è badare più alla quantità e aggiornamento dei pacchetti che alla loro qualità e integrazione.

    • #27214
      Silvan
      Amministratore del forum

      Quello che racconti è un tipico caso che evidenzia come sia complicato avere un sistema aggiornato che possa funzionare in tutte le configurazioni anche le più vecchie. Comunque nella versione milestone2 non ci saranno ulteriori aggiornamenti maggiori del sottosistema grafico per cui la tua configurazione dovrebbe continuare a funzionare correttamente anche dopo gli aggiornamenti futuri. In linea con quanto dici, nella versione stabile vengono effettuati solo gli aggiornamenti che servono per risolvere problemi riscontrati dagli utenti oppure gli aggiornamenti di applicazioni che introducono bugfix importanti o che non sono ancora ad uno stato veramente stabile (come per esempio qui nel forum si è discusso su kdenlive).

    • #27215
      gigi
      Membro

      ecco il link al pessimo annuncio:

      http://www.mesa3d.org/systems.html

      mi sembra che per questo ubuntu abbia congelato l’aggiornamento di X; io ancora non ho trovato forum dove ci si occupi della cosa, o siti dove ci siano iniziative per l’adeguamento dei vecchi driver…non credo di esser l’unico con un portatile datato ma ancora efficente…

      qualcuno ha info?

      ps:claws-mail e nomacs sono ok

    • #27216
      Silvan
      Amministratore del forum

      Mi pare che Ubuntu e altri vorrebbero proprio abbandonare X, ma praticamente questa scelta sarebbe ancora peggio per ciò che riguarda la compatibilità con i driver vecchi. Oggi nessuno o quasi tra quelli che sono in grado di farlo ha interesse a sviluppare o mantenere driver per chipset vecchi. C’è anche da dire che gli ambienti desktop tendono a dare sempre più per scontato la disponibilità del supporto per accelerazioni grafiche moderne (vedasi Gnome 3+) e quindi in ogni caso un sistema aggiornato e moderno non andrebbe al pieno delle funzionalità con hardware datato. Quindi penso sia in parte inevitabile che su computer più vecchi ci si debba accontentare di versioni più vecchie del s.o., però magari ancora mantenute per stare al passo con il mondo moderno all’esterno, quindi per esempio per la navigazione internet. Un altro esempio è che nel kernel linux è stato recentemente abbandonato il supporto per i vecchi i386. Nel nostro caso rimarrà disponibile la versione milestone2 (e volendo anche milestone1) se la versione milestone3 sarà più adatta ad hardware recente. Comunque se non altro nel mondo Linux la situazione è già molto migliore che altrove, per esempio se hai un Mac basato su PowerPC (non vecchissimo, per esempio un ibook del 2005) oggi con MacOSX non riesci a fare più molto sul web perchè i browser non sono più aggiornati e mantenuti (e infatti questi computer si recuperano installando una versione di Linux per PowerPC).

    • #27217
      gigi
      Membro

      l’evoluzione e la decadenza sono inevitabili ad un certo punto…

      Ma per fare cose base, che comunque implicano un po di accelerazione, mi sembra assurdo avere pc strapotenti.

      il mio athlon da 2g corre ancora bene se non faccio 3d peso e per fogli elettronici, grafica e video, con firewire e usb2 e un buon os, sono a posto!

      Per questo spero di non trovarmi un foglio di calcolo che ha bisogno dell’ultima implementazione del 3d…al limite si possono usare differenti versioni di librerie.

      ciao.

Visualizzazione 10 filoni di risposte
  • Devi aver eseguito l’accesso per poter rispondere a questa discussione.