Processore sempre 100%

Home Page Forum utenti Processore sempre 100%

Questo argomento contiene 8 risposte, ha 3 partecipanti, ed è stato aggiornato da  fredflinstone 3 mesi, 2 settimane fa.

  • Autore
    Articoli
  • #32823

    fredflinstone
    Partecipante

    Ciao !

    E’ possibile che il processore del mio pc sia sempre al 100 % pur utilizzando pochi programmi, perlopiù testo o internet ?

    queste le caratteristiche :

    Sistema operativo: openmamba 4.93.0
    Versione di KDE Plasma: 5.15.5
    Versione di KDE Frameworks: 5.58.0
    Versione di Qt: 5.12.3
    Versione del Kernel: 4.14.94mamba
    Tipo sist.operativo: 32-bit
    Processori: 2 × Intel® Pentium® CPU G620 @ 2.60GHz
    Memoria: 2,9 GiB di RAM

    grazie.

  • #32824

    Silvan
    Keymaster

    Ciao,
    premessa: ad oggi per usare la maggior parte dei sistemi desktop moderni, compreso un S.O. Linux con KDE 5, sarebbero raccomandati almeno 4 GB di RAM, un processore quad-core ed un sistema operativo a 64 bit. openmamba essendo finalizzato all’uso come sistema operativo per la produttività non ha come target il riuso di PC troppo “vecchi”, per questo scopo è disponibile una versione con desktop leggero LXDE, ma ci sono probabilmente altre distribuzioni Linux più adatte.
    Detto questo nell’uso normale la principale causa di un utilizzo elevato di memoria (e conseguente elevato utilizzo di CPU e I/O per swapping su disco della memoria RAM insufficiente) è il browser Chromium, che posso suggerire di sostituire con Firefox.
    Per invidivuare comunuqe la causa in modo più specifico, sia che si tratti di un effettivo problema di qualche processo oppure di normale utilizzo delle risorse, il primo passo è di utilizzare un gestore di processi come “KSysGuard – Monitor di sistema”, il comando top da linea di comando, oppure richiedere una nostra valutazione del problema generando ed inviando un “Report del sistema openmamba”.

  • #32825

    fredflinstone
    Partecipante

    Ciao !

    Vero ! il mio pc è vecchietto, come me ! ma per l’ uso che ne faccio è sufficente.
    LXDE non l’ ho mai digerito.
    Openmamba mi ha sempre soddisfatto ed ha il valore aggiunto di essere una distro nostrana ma soprattutto ben fatta.
    Detto questo comando top :

    top – 09:40:04 up 16 min, 1 user, load average: 5,34, 5,27, 3,60
    Tasks: 167 total, 7 running, 159 sleeping, 0 stopped, 1 zombie
    %Cpu(s): 58,1 us, 23,8 sy, 16,4 ni, 0,0 id, 0,0 wa, 0,0 hi, 1,8 si, 0,0 st
    MiB Mem : 2947,6 total, 435,2 free, 825,7 used, 1686,7 buff/cache
    MiB Swap: 8000,0 total, 8000,0 free, 0,0 used. 1629,5 avail Mem

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    3822 claudio 20 0 243092 66720 48568 R 31,8 2,2 3:44.57 kded5
    4341 claudio 39 19 1150716 23492 21460 R 31,8 0,8 7:22.82 baloo_file_extr
    4052 claudio 20 0 39144 14032 6236 S 29,2 0,5 3:37.16 python
    3860 claudio 20 0 825180 226440 110664 R 28,7 7,5 3:17.37 plasmashell
    4379 claudio 20 0 1163832 24536 19552 R 20,5 0,8 3:10.37 tags.so
    3790 claudio 20 0 7828 5396 3644 S 19,0 0,2 2:25.98 dbus-daemon
    2145 root 20 0 536244 317340 316192 S 13,3 10,5 1:51.07 systemd-journal
    3856 claudio 39 19 1148076 21928 19124 S 8,7 0,7 1:56.04 baloo_file
    4230 claudio 20 0 544204 197436 81772 S 8,2 6,5 0:04.20 WebExtensions
    4759 claudio 20 0 178868 71236 31988 S 5,1 2,4 0:17.18 transmission-gt
    3955 claudio 20 0 1044916 291700 155244 S 1,0 9,7 0:32.85 firefox-bin
    3658 root 20 0 125232 69968 56260 S 0,5 2,3 0:15.78 X
    4163 claudio 20 0 524812 176208 121472 S 0,5 5,8 0:08.11 Web Content
    4811 claudio 20 0 11516 3632 3112 R 0,5 0,1 0:00.22 top
    1 root 20 0 34852 8796 7024 S 0,0 0,3 0:02.62 systemd
    2 root 20 0 0 0 0 S 0,0 0,0 0:00.00 kthreadd
    4 root 0 -20 0 0 0 I 0,0 0,0 0:00.00 kworker/0:0H
    5 root 20 0 0 0 0 I 0,0 0,0 0:00.15 kworker/u4:0
    6 root 0 -20 0 0 0 I 0,0 0,0 0:00.00 mm_percpu_wq
    7 root 20 0 0 0 0 S 0,0 0,0 0:00.18 ksoftirqd/0
    8 root 20 0 0 0 0 I 0,0 0,0 0:01.87 rcu_preempt
    9 root 20 0 0 0 0 I 0,0 0,0 0:00.01 rcu_sched
    10 root 20 0 0 0 0 I 0,0 0,0 0:00.00 rcu_bh

    Grazie !

  • #32826

    fredflinstone
    Partecipante

    Ciao !

    per curiosità ti allego il risultato del comando top in una sessione root. Qui il processore è utilizzato al 2%, nonostante firefox.

    top – 13:16:39 up 3:53, 3 users, load average: 0,44, 0,53, 0,54
    Tasks: 206 total, 1 running, 204 sleeping, 0 stopped, 1 zombie
    top – 13:22:23 up 3:59, 3 users, load average: 0,00, 0,23, 0,40
    Tasks: 204 total, 1 running, 202 sleeping, 0 stopped, 1 zombie
    %Cpu(s): 0,8 us, 1,2 sy, 0,0 ni, 98,0 id, 0,0 wa, 0,0 hi, 0,0 si, 0,0 st
    MiB Mem : 2947,6 total, 206,4 free, 2059,7 used, 681,4 buff/cache
    MiB Swap: 8000,0 total, 3668,4 free, 4331,6 used. 424,9 avail Mem

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    9193 root 20 0 190048 57180 47408 S 1,0 1,9 0:02.08 konsole
    8949 root 19 -1 99312 49776 35848 S 0,7 1,6 0:07.62 X
    9034 root 20 0 332716 88768 60516 S 0,7 2,9 0:08.74 kwin_x11
    1 root 20 0 35876 4496 3232 S 0,3 0,1 0:03.00 systemd
    9028 root 20 0 88052 16600 15132 S 0,3 0,5 0:00.07 kscreen_backend
    9038 root 20 0 601564 197860 98988 S 0,3 6,6 0:08.63 plasmashell
    2 root 20 0 0 0 0 S 0,0 0,0 0:00.00 kthreadd
    4 root 0 -20 0 0 0 I 0,0 0,0 0:00.00 kworker/0:0H
    6 root 0 -20 0 0 0 I 0,0 0,0 0:00.00 mm_percpu_wq
    7 root 20 0 0 0 0 S 0,0 0,0 0:03.49 ksoftirqd/0
    8 root 20 0 0 0 0 I 0,0 0,0 0:28.38 rcu_preempt
    9 root 20 0 0 0 0 I 0,0 0,0 0:00.33 rcu_sched
    10 root 20 0 0 0 0 I 0,0 0,0 0:00.00 rcu_bh
    11 root rt 0 0 0 0 S 0,0 0,0 0:00.00 migration/0
    12 root rt 0 0 0 0 S 0,0 0,0 0:00.02 watchdog/0
    13 root 20 0 0 0 0 S 0,0 0,0 0:00.00 cpuhp/0
    14 root 20 0 0 0 0 S 0,0 0,0 0:00.00 cpuhp/1
    15 root rt 0 0 0 0 S 0,0 0,0 0:00.02 watchdog/1
    16 root rt 0 0 0 0 S 0,0 0,0 0:00.00 migration/1
    17 root 20 0 0 0 0 S 0,0 0,0 0:00.39 ksoftirqd/1
    19 root 0 -20 0 0 0 I 0,0 0,0 0:00.00 kworker/1:0H
    20 root 20 0 0 0 0 S 0,0 0,0 0:00.00 kdevtmpfs
    21 root 0 -20 0 0 0 I 0,0 0,0 0:00.00 netns

    Come mai tale discrepanza ?

    Grazie per rispondere alle mie paturnie informatiche !

  • #32827

    fredflinstone
    Partecipante

    Ciao !

    Avendo notato che il programma baloo mangia un casino di risorse ho provato a disinstallarlo.
    ora il processore lavora decisamente meglio.
    Se ho fatto una bestialità vi prego di dirmelo.
    Grazie

    questo il risultato attraverso top

    top – 18:38:02 up 11 min, 1 user, load average: 0,04, 0,44, 0,47
    Tasks: 164 total, 1 running, 162 sleeping, 0 stopped, 1 zombie
    %Cpu(s): 1,2 us, 0,5 sy, 0,0 ni, 98,2 id, 0,2 wa, 0,0 hi, 0,0 si, 0,0 st
    MiB Mem : 2947,6 total, 1194,1 free, 622,0 used, 1131,5 buff/cache
    MiB Swap: 8000,0 total, 8000,0 free, 0,0 used. 1884,1 avail Mem

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    3976 claudio 20 0 189172 56716 47168 S 1,0 1,9 0:00.95 konsole
    3500 root 20 0 2320 1224 1156 S 0,7 0,0 0:00.65 acpid
    3705 root 20 0 103552 56008 41072 S 0,7 1,9 0:10.19 X
    3900 claudio 20 0 232308 64976 53904 S 0,7 2,2 0:04.09 kwin_x11
    3907 claudio 20 0 846284 222096 111972 S 0,7 7,4 0:10.95 plasmashell
    4978 claudio 20 0 11516 3400 3036 R 0,7 0,1 0:00.03 top
    4890 claudio 20 0 479640 118068 81460 S 0,3 3,9 0:01.87 WebExtensions
    1 root 20 0 34840 9016 7240 S 0,0 0,3 0:02.65 systemd
    2 root 20 0 0 0 0 S 0,0 0,0 0:00.00 kthreadd
    4 root 0 -20 0 0 0 I 0,0 0,0 0:00.00 kworker/0:0H
    6 root 0 -20 0 0 0 I 0,0 0,0 0:00.00 mm_percpu_wq
    7 root 20 0 0 0 0 S 0,0 0,0 0:00.17 ksoftirqd/0
    8 root 20 0 0 0 0 I 0,0 0,0 0:00.46 rcu_preempt
    9 root 20 0 0 0 0 I 0,0 0,0 0:00.03 rcu_sched
    10 root 20 0 0 0 0 I 0,0 0,0 0:00.00 rcu_bh
    11 root rt 0 0 0 0 S 0,0 0,0 0:00.00 migration/0
    12 root rt 0 0 0 0 S 0,0 0,0 0:00.00 watchdog/0
    13 root 20 0 0 0 0 S 0,0 0,0 0:00.00 cpuhp/0
    14 root 20 0 0 0 0 S 0,0 0,0 0:00.00 cpuhp/1
    15 root rt 0 0 0 0 S 0,0 0,0 0:00.00 watchdog/1
    16 root rt 0 0 0 0 S 0,0 0,0 0:00.00 migration/1
    17 root 20 0 0 0 0 S 0,0 0,0 0:00.08 ksoftirqd/1
    19 root 0 -20 0 0 0 I 0,0 0,0 0:00.00 kworker/1:0H

  • #32829

    Silvan
    Keymaster

    Ciao,
    bene per aver trovato la causa del problema.

    baloo credo sia richiesto se si usano alcune funzionalità di KDE come la posta (kontact) ed esercita una funzione utile.

    In passato ha dato più problemi, mentre negli ultimi anni non l’ho più individuato come causa di pesantezza e rallentamenti. C’è da considerare che una volta finita l’indicizzazione iniziale dei files poi lavora molto di meno.

    In questo caso potrebbe essere sintomo di disco particolarmente lento o di uno o più files particolarmente grossi.

    Al posto di rimuovere il pacchetto potrebbe anche essere una soluzione aprire l’applicazione “Ricerca dei file” ed agire sulle opzioni di configurazione per alleggerirne il lavoro (ad esempio: Indicizza anche il contenuto dei files => disattivato).

  • #32830

    fredflinstone
    Partecipante

    Ciao !

    Ho provato quanto suggerito ma al riavvio baloo mi utilizza al 61,1% il processore

    4430 claudio 39 19 1150636 22768 20840 S 61,1 0,8 1:24.82 baloo_file_extr

    ho provato anche questo :

    sudo balooctl disable

    ottenedo questa risposta .

    QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to ‘/tmp/runtime-root’
    Disabling the File Indexer

    eppure lanciando top baloo continua a lavorare

    4430 claudio 39 19 1150636 22768 20840 S 58,8 0,8 3:36.64 baloo_file_extr

    Ti ringrazio per la risposta.

  • #32831

    ercolinux
    Moderatore

    Ciao, devi lanciarlo senza sudo: il comando disabilita baloo per l’utente corrente, con sudo l’utente diventa root invece del tuo.

  • #32832

    fredflinstone
    Partecipante

    Ciao !

    fatto ! ti ringrazio per il suggerimento.

Devi aver eseguito l’accesso per poter rispondere a questa discussione.