problema codec video

Home Page Forum generale problema codec video

Visualizzazione 6 filoni di risposte
  • Autore
    Articoli
    • #34015
      fredflinstone
      Partecipante

      Ciao !

      Segnalo che dopo una recentissima nuova installazione di openmamba, vlc ed mplayer non riproducono correttamente alcuni formati video, per esempio mpeg4 o addirittura un banalissimo avi. I pacchetti sono quelli nativi openmamba

      Installando vlc nel pacchetto flatpack invece il programma funziona correttamente.

      Allego per completezza un report di sistema.

      Grazie.

    • #34020
      Silvan
      Amministratore del forum

      Ciao,
      non riscontro problemi generali nella riproduzione di file mp4 e altri a campione su diverse installazioni di openmamba.
      Al fine di diagnosticare la causa che impedisce la riproduzione di tagli contenuti nella tua installazione sarebbe utile eseguire vlc da una finestra di terminale, riprodurre il problema tentando di aprire un file video e poi copiare l’output completo che è stato generato da vlc sul terminale affinché possa venire esaminato.

    • #34022
      fredflinstone
      Partecipante

      Ciao !

      ” VLC media player 3.0.20 Vetinari (revision 3.0.20-0
      -g6f0d0ab126b)
      [0000555b13d24550] main libvlc: Esecuzione di vlc c
      on l’interfaccia predefinita. Usa ‘cvlc’ per utiliz
      zare vlc senza interfaccia.
      [0000555b13dbf140] main playlist: playlist is empty
      [00007f436c6570b0] upnp services discovery: Initial
      izing libupnp on ‘default’ interface
      uint DBusMenuExporterDBus::GetLayout(int, int, cons
      t QStringList&, DBusMenuLayoutItem&): Condition fai
      led: menu
      uint DBusMenuExporterDBus::GetLayout(int, int, cons
      t QStringList&, DBusMenuLayoutItem&): Condition fai
      led: menu
      uint DBusMenuExporterDBus::GetLayout(int, int, cons
      t QStringList&, DBusMenuLayoutItem&): Condition fai
      led: menu
      uint DBusMenuExporterDBus::GetLayout(int, int, cons
      t QStringList&, DBusMenuLayoutItem&): Condition fai
      led: menu
      uint DBusMenuExporterDBus::GetLayout(int, int, cons
      t QStringList&, DBusMenuLayoutItem&): Condition fai
      led: menu
      uint DBusMenuExporterDBus::GetLayout(int, int, cons
      t QStringList&, DBusMenuLayoutItem&): Condition fai
      led: menu
      uint DBusMenuExporterDBus::GetLayout(int, int, cons
      t QStringList&, DBusMenuLayoutItem&): Condition fai
      led: menu
      uint DBusMenuExporterDBus::GetLayout(int, int, cons
      t QStringList&, DBusMenuLayoutItem&): Condition fai
      led: menu
      uint DBusMenuExporterDBus::GetLayout(int, int, cons
      t QStringList&, DBusMenuLayoutItem&): Condition fai
      led: menu
      uint DBusMenuExporterDBus::GetLayout(int, int, cons
      t QStringList&, DBusMenuLayoutItem&): Condition fai
      led: menu
      uint DBusMenuExporterDBus::GetLayout(int, int, cons
      t QStringList&, DBusMenuLayoutItem&): Condition fai
      led: menu
      uint DBusMenuExporterDBus::GetLayout(int, int, cons
      t QStringList&, DBusMenuLayoutItem&): Condition fai
      led: menu
      uint DBusMenuExporterDBus::GetLayout(int, int, cons
      t QStringList&, DBusMenuLayoutItem&): Condition fai
      led: menu
      uint DBusMenuExporterDBus::GetLayout(int, int, cons
      t QStringList&, DBusMenuLayoutItem&): Condition fai
      led: menu
      uint DBusMenuExporterDBus::GetLayout(int, int, cons
      t QStringList&, DBusMenuLayoutItem&): Condition fai
      led: menu
      [0000555b13e08d50] main audio output error: too low
      audio sample frequency (0)
      [00007f4304537a40] main decoder error: failed to cr
      eate audio output
      [0000555b13e08d50] vlcpulse audio output error: dig
      ital pass-through stream connection failure: Non su
      pportato
      [0000555b13e08d50] main audio output error: module
      not functional
      [00007f4304537a40] main decoder error: failed to cr
      eate audio output
      uint DBusMenuExporterDBus::GetLayout(int, int, cons
      t QStringList&, DBusMenuLayoutItem&): Condition fai
      led: menu
      libva info: VA-API version 1.20.0
      libva info: Trying to open /usr/lib64/dri/r600_drv_
      video.so
      libva info: Found init function __vaDriverInit_1_20
      libva info: va_openDriver() returns 0
      [00007f4304011be0] avcodec decoder: Using G3DVL VDP
      AU Driver Shared Library version 1.0 for hardware d
      ecoding
      [00007f4304011be0] main decoder error: Timestamp co
      nversion failed for 48215001: no reference clock
      [00007f4304011be0] main decoder error: Could not co
      nvert timestamp 0 for FFmpeg ”

      Spero sia sufficente.

      Grazie

    • #34023
      Silvan
      Amministratore del forum

      La mia installazione con GPU ATI/AMD sta usando il driver modesetting, la tua starebbe usando il driver xorg-drv-video-ati.

      Proverei a switchare a modesetting rimuovendo la vecchia interfaccia per X.org:

      sudo dnf remove xorg-drv-video-ati

      e riavvio. In caso di problemi per tornare indietro basta reinstallare il pacchetto rimosso.

      • Questa risposta è stata modificata 4 mesi, 2 settimane fa da Silvan.
    • #34025
      fredflinstone
      Partecipante

      Ciao !

      Ho fatto come descritto ma vlc  non riproduce il video selezionato in questo caso un file mp4.  Aggiungo che anche mplayer da lo stesso problema.

      Posto l’ output da terminale :

      ” VLC media player 3.0.20 Vetinari (revision 3.0.20-0
      -g6f0d0ab126b)
      [0000561c7288c550] main libvlc: Esecuzione di vlc c
      on l’interfaccia predefinita. Usa ‘cvlc’ per utiliz
      zare vlc senza interfaccia.
      [0000561c72927140] main playlist: playlist is empty
      uint DBusMenuExporterDBus::GetLayout(int, int, cons
      t QStringList&, DBusMenuLayoutItem&): Condition fai
      led: menu
      uint DBusMenuExporterDBus::GetLayout(int, int, cons
      t QStringList&, DBusMenuLayoutItem&): Condition fai
      led: menu
      libva info: VA-API version 1.20.0
      libva info: Trying to open /usr/lib64/dri/r600_drv_
      video.so
      libva info: Found init function __vaDriverInit_1_20
      libva info: va_openDriver() returns 0
      [00007f370f249590] avcodec decoder: Using G3DVL VDP
      AU Driver Shared Library version 1.0 for hardware d
      ecoding
      [00007f370f249590] main decoder error: Timestamp co
      nversion failed for 8041667: no reference clock
      [00007f370f249590] main decoder error: Could not co
      nvert timestamp 0 for FFmpeg
      [00007f370f249590] main decoder error: Timestamp co
      nversion failed for 2663666667: no reference clock
      [00007f370f249590] main decoder error: Could not co
      nvert timestamp 0 for FFmpeg ”

      Grazie.

    • #34026
      Silvan
      Amministratore del forum

      L’output di VLC non è molto utile, gli ultimi errori non sarebbero bloccanti ed in tal caso sembrerebbe che VLC stia riproducendo il video ma probabilmente vedi uno schermo nero. Se fosse questo il caso proverei a disattivare il compositore degli effetti 3D nelle impostazioni di KDE Plasma.

      Non saprei al momento cos’altro suggerire se non, volendo, di fare test sparsi per avere maggiori informazioni, ad esempio:
      – se il problema si verifica con determinati files mp4 e avi ma non si verifica con altri si tratterebbe di un problema di decodifica
      – andare nelle impostazioni delle accelerazioni hardware di VLC e cambiare metodo per verificare se e quali funzionano
      – vedere anche il log di mplayer, e se anche quest’ultimo apparentemente riproduce il file ma non si vede
      – …

       

      • Questa risposta è stata modificata 4 mesi, 2 settimane fa da Silvan.
    • #34028
      fredflinstone
      Partecipante

      Ciao !

      ti ringrazio per la dritta… disabilitando l’ accelerazione hardware in vlc il problema è risolto.

       

      Grazie.

Visualizzazione 6 filoni di risposte
  • Devi aver eseguito l’accesso per poter rispondere a questa discussione.