Installazione di OM in VirtualBox su Win10

Home Page Forum utenti Installazione di OM in VirtualBox su Win10

Visualizzazione 11 filoni di risposte
  • Autore
    Articoli
    • #32486
      bottye
      Partecipante

      Ciao,

      vorrei installare OM sotto W10 in una VM.
      Ho letto i vecchi post relativi alla Milestone2 ma non ne vengo a capo 🙁

      Dopo le prime 2 videate in cui scelgo la Lingua e la “versione” [default 4.14 ma per le altre a 32 bit è identico]
      mi viene dato un errore di “guru meditation” con una videata di sfondo nera senza scritte.

      Il log che viene fornito è in allegato.
      A naso parrebbe una questione di scheda video, ma non me ne intendo…

      La versione che provo ad installare è la:
      openmamba-livedvd-en-snapshot-20180309.i586.iso
      la 64 bit pare non sia supportata.

      In allegato anche una videata con le impostazioni della VM.

      Grazie
      E-

    • #32488
      bottye
      Partecipante

      Errori di caricamento:

      VBox.log: Sorry, this file type is not permitted for security reasons.

      Per errore di caricamento il file log te l’ho inviato come report:

      VBox.log.txt

      con descrizione:

      [Richiesta di supporto] Installazione di OM in VirtualBox su Win10

      Grazie
      E-

    • #32490
      Silvan
      Amministratore del forum

      Ciao,
      ho fatto delle verifiche su VirtualBox per Linux (openmamba) affrontando alcune problematiche relative all’avvio dell’ambiente grafico nelle diverse modalità possibili. Per quanto riguarda il log di VirtualBox su Windows non sono in grado di dire nulla in quanto verosimilmente si tratta di un problema esterno.
      Suggerimenti:
      1) aumentare la RAM, 1GB è poco per l’ambiente KDE Plasma e se non è disponibile un disco con partizione Swap alcuni processi potrebbero andare in crash per mancanza di memoria
      2) provare un’opzione di avvio senza il supporto modeset, ad esempio selezionando l’opzione del menù di avvio di openmamba come da immagine allegata
      3) le attuali versioni live di openmamba forniscono un kernel a 32 bit con un’impostazione che impedisce il caricamento del driver vboxvideo, questo è stato corretto con un aggiornamento del kernel:
      – mamba, mamba-64GB: unset CONFIG_GCC_PLUGIN_RANDSTRUCT and CONFIG_OF_UNITTEST
      4) per i motivi di cui al punto 3) al momento sarebbe meglio usare la versione a 64 bit, se possibile. Non so perché, ma mi sembra strano che, sulla base di quanto dici, l’avvio di un guest a 64 bit non sia supportato, ma trattandosi di Windows per me tutto può essere. Per questo comunque mi assicurerei che il supporto VT-X sia abilitato nel BIOS del computer, su molti computer è disabilitato di default. Vedi ad esempio: https://helpdeskgeek.com/how-to/enable-virtualization-in-the-bios/

    • #32494
      bottye
      Partecipante

      Ciao,

      sono riuscito in parte nel mio intento…
      Ho installato il SO come 64, ma era una iso del 21/03/18
      [openmamba-livedvd-en-snapshot-20180309.x86_64.iso]
      dovevo riscaricarla?

      Dico questo perchè avviandola si blocca alla schermata allegata…
      [ho provato con e senza supporto di rete ma non cambia nulla…]

      Ho allegato anche le impostazioni della VM.

      – Ho provato anche con la base del SO su OtherLinux 64… –

      Grazie
      E-

      Attachments:
    • #32496
      bottye
      Partecipante

      oops mancavano le impostazioni….

      Attachments:
    • #32498
      Silvan
      Amministratore del forum

      Ciao,
      hai provato anche l’avvio in modalità nomodeset seguendo istruzioni analoghe a quelle del mio ultimo post riferito alla versione a 32 bit, ovvero lo screenshot allegato? Per poter accedere a tale menù occorre premere rapidamente un tasto freccia non appena il menù compare.

    • #32500
      bottye
      Partecipante

      Ciao,

      no buono, stesso errore di prima [videata nera con scritte: [nnnnnn] Spectre V2….]

      3) le attuali versioni live di openmamba forniscono un kernel a 32 bit con un’impostazione che impedisce il caricamento del driver vboxvideo, questo è stato corretto con un aggiornamento del kernel:
      – mamba, mamba-64GB: unset CONFIG_GCC_PLUGIN_RANDSTRUCT and CONFIG_OF_UNITTEST

      Quando parlavi del punto 3 di cui sopra io dovevo far qualcosa?

      Ho provato, dopo l’installazione (fatta con x64 e l’opzione NOMODESET 800×600 — abilitando la virtualizzazione ti da la possibilità di installare anche a 64bit altrimenti solo a 32), [l’ho fatto su una nuova VM]
      a non far riavviare subito [tramite apposita spunta prima di premere Fatto dal programma di installazione
      e a spegnere OM Live con i comandi soliti da interfaccia ed il risultato è come in allegato…
      si è bloccato lì e ho dovuto spegnere la VM.

      Ho messo anche le impostazioni della nuova VM che mi sembra siano le stesse della perecedente.

      Grazie
      E-

      • Questa risposta è stata modificata 3 anni, 6 mesi fa da bottye.
    • #32613
      bottye
      Partecipante

      Ciao,
      finalmente ho potuto rimetter mano alla cosa ripartendo da 0.

      Ho generato una VM con openmamba-livedvd-en-snapshot-20180409.x86_64.iso
      con le impostazioni di cui in allegato e in No Modeset 1024… [la seconda opzione].

      Ha installato tutto per benino e al riavvio sembrava partire ma mi ha poi dato l’errore bloccante:

      Spectre V2 : Spectre mitigation: LFENCE not serializing, switch to generic retpoline
      🙁
      Come posso impostare il No Modeset all’avvio, se è quello che non fa funzionare il tutto?

      Ho trovato anche questo riferimento, non so se sia utile:
      AMD CPUs & LFENCE-[SOLVED]

      Grazie
      E-

    • #32615
      Silvan
      Amministratore del forum

      Ciao,
      per avviare in modalità ‘nomodeset’ dopo l’installazione bisongna selezionare nel menù che compare all’avvio (Grub) il sottomenù delle ‘Opzioni avanzate’ e poi l’avvio in modalità ‘Driver proprietari’ che equivale a nomodeset. Così il sistema si avvia correttamente?

      • Questa risposta è stata modificata 3 anni, 3 mesi fa da Silvan.
    • #32617
      bottye
      Partecipante

      Grazie, si, così funziona!

      Grandioso!

      Adesso devo solo più installarvi i sistemi di grafica GIMP, Blender, &C e di sviluppo PHP&C, Java [JDK&C] &…

      Ottimo!
      E-

    • #32618
      bottye
      Partecipante

      Ora mi trovo col problema di farlo andare in rete.

      Ho provato varie impostazioni ma non so quale sia quella giusta.
      Sono in WiFi e vado in rete attraverso una VPN Pulse Secure…

      Dovrei avere tra l’altro una doppia configurazione anche per quando uso la LAN…

      Grazie
      E-

    • #32619
      Silvan
      Amministratore del forum

      Ciao,
      se l’host con VirtualBox è in rete in teoria il guest openmamba dovrebbe uscire correttamente se configurato come NAT (vedo dalle impostazioni che è configurato così). Non so però come funzioni il servizio di rete che stai utilizzando ed il problema potrebbe anche dipendere da VirtualBox e l’host con Windows. Hai altre macchine virtuali sullo stesso host? Come sono configurate per uscire in rete?

Visualizzazione 11 filoni di risposte
  • Devi aver eseguito l’accesso per poter rispondere a questa discussione.