hard disk usb esterno

Home Page Forum generale hard disk usb esterno

Questo argomento contiene 11 risposte, ha 5 partecipanti, ed è stato aggiornato da  casimiroandrea 11 anni, 7 mesi fa.

  • Autore
    Articoli
  • #17819

    Ho riscontrato uno strano problema all’ inserimento del mio hard disk usb contenente tutti i file dati presenti nel mio windows xp. Ogni qualvolta inserisco il disco e apro la periferica automontata mi compare questa scritta

    ” $LogFile indicates unclean shutdown (0, 0) Failed to mount ‘/dev/sda1’: Operation not supported Mount is denied because NTFS is marked to be in use. Choose one action: Choice 1: If you have Windows then disconnect the external devices by clicking on the ‘Safely Remove Hardware’ icon in the Windows taskbar then shutdown Windows cleanly. Choice 2: If you don’t have Windows then you can use the ‘force’ option for your own responsibility. For example type on the command line: mount -t ntfs-3g /dev/sda1 /media/disk -o force Or add the option to the relevant row in the /etc/fstab file: /dev/sda1 /media/disk ntfs-3g force 0 0 “

    Come posso risolvere questo problema ?? Vorrei recuperare i miei vecchi dati presenti nel disco.

    grazie 1000

  • #24198

    marcpaa
    Membro

    Ciao,il motivo è che winzoz è una merda!!!!!!!!!!!!!!!!!!!!!!!

    Scherzo ma nn più di tanto, infatti il problema è che il tuo hard esterno lo hai (magari incosapevolmente) formattato con filesistem NTFS ed almeno per adesso a Linux non è permesso scrivere su di esso.(invece con un bel fat32 non c’erano problemi)

    Per fortuna qualcuno ci ha pensato e si chiama ntfs-3g un progammino che permette di scrivere su ntfs.

    Ora per poter leggere e scrivere il file sull’hd ext dovresti fare il mount, e consiste appunto come ti dice l’otput:


    For example type on the command line: mount -t ntfs-3g /dev/sda1 /media/disk -o force Or add the option to the relevant row in the /etc/fstab file: /dev/sda1 /media/disk ntfs-3g force 0 0 “


    Prova dalla shell loggato come root a dare:

    mount -t ntfs-3g /dev/sda1 /media/disk -o force

    dove al posto di sda1 dovresti inserire quello corretto (non è escluso che lo sia)


    Or add the option to the relevant row in the /etc/fstab file: /dev/sda1 /media/disk ntfs-3g force 0 0


    Oppure come ti dice puoi provare a modificare il file che trovi in /etc e si chiame fstab

    e aggiungere le righe che ti suggerisce: /dev/sda1 /media/disk ntfs-3g force 0 0

    Anche quì come sopra,penso che sda1 sia giusto,però non posso esserne sicuro dato che non conosco come sono state fatte le partizioni.

    Se ti serve altro posta e vedremo,

    Un saluto

    P.S Se risolvi posta la soluzione da te usata,servira ad altri che avranno il tuo stesso problema.

  • #24210

    ciao,

    ho messo in pratica tutte e due i consigli che mi hai dati , ma mentre il primo ( da kconsole come root) mi da un errore, per il secondo invece ho inserito nel file fstab la riga consigliata , ma non cambia nulla.

    cosa mi consigli.

    fammi sapere.

  • #24212

    hackerberry
    Membro

    Smonta l’hard disk esterno direttamente da windows

  • #24214

    ciao HACKERBERRY grazie per il consiglio ma non ho capito cosa vuol dire smonta l’ hard disk da windows

  • #24215

    marcpaa
    Membro

    Ciao, hai controllato che la partizione sia quella giusta?


    Prova dalla shell loggato come root a dare:

    mount -t ntfs-3g /dev/sda1 /media/disk -o force

    dove al posto di sda1 dovresti inserire quello corretto (non è escluso che lo sia)


    Al posto di sda1 devi inserire la partizione giusta.

    Ora presumo che non sai quale sia!

    mi occorrono dei dati su come hai partizionato l’hd interno, è più precisamente voglio sapere:

    1) è un pc fisso o portatile?

    2) gli hd che interfaccia hanno? ide o sata?

    3) mi occorre una “tabella” su come hai partizionato l’hd,quindi dal menu k


    Sistema


    kinfocenter


    dispositivi di memorizzazione.

    Postami tutto (puoi tralasciare le colonne pieno e libero)

    Lo fai sia con hd ext inserito che senza, attenzione aspetta qualche minuto dopo aver inserito l’hd ext.(per vedere se cambia qualcosa)

    A proposito la riga in fstab cvhe hai aggiunto è meglio che la rimuovi per il momento.


    In pratica bisogna bisogna sapere che partizione da il sistema all’hd ext, quindi se sda1

    non ti funziona vuol dire che deve essere altro esempio sdc1.

    Un saluto a più tardi

    P.S. (aggiungo)

    Prima di fare quanto elencato sopra prova così:

    da hd ext inserito,(attendi un minuto dopo averlo inserito) vai su menuk


    sistema—-gparted

    (ti chiederà la pass di root,mi raccomando se non sai usare gparted non fare più di quello che ti dico,puoi rischiare di cancellare intere partizioni) appena si apre il programma in alto a dx trovi un quadratino con es. /dev/sda (232.38 gb)ed una freccietta nera, se te lo fa fare clicca sulla freccietta e dovrebbe uscirti l’elenco dei dispositivi con le capienze, se è elencato l’hd ext e lo riconosci (non dovrebbe essere complicato) segnati il device (es. /dev/sdf1)

    Per finire non resta altro che inserire il giusto device sdf1 al posto do sda1 e provare se funge.

  • #24224

    ciao,

    ho fatto quanto da te consigliato ed il risultato è il seguente :

    [root@n-linux Casimiro]# mount -t ntfs-3g /dev/sda1 /media/disk -o force

    $LogFile indicates unclean shutdown (0, 0)

    WARNING: Forced mount, reset $LogFile.

    ntfs-3g-mount: failed to access mountpoint /media/disk: No such file or director y

    [root@n-linux Casimiro]#

    Ti assicuro che la periferica risulta essere la ” sda1 “.

    Penso che la soluzione sia quello di collegarlo ad un pc windows copiare il contenuto , formattare l’ hard ext in fat32 e poi ricopiare il tutto.

    Cosa ne pensi ??

  • #24225

    marcpaa
    Membro

    Ciao,e sempre una soluzione ma……………..io proverei altro,

    Cmq mi posti il file fstab?

    Sai se il tuo pc usa hd sata o ide? penso ide altrimenti non ti chiamava l’hd ext sda1,però se me lo confermi e meglio.

    Sembra che manchi la dir in /media

    prova così,(però dopo averti accertato che le partizioni dell’hd del pc,quello int., siano hda e non sda)

    da shell (ti conviene come root)

    cd /media (invio)

    poi dai:

    mkdir sda1 (invio)

    poi dai :

    ls (invio)

    e controlla che abbia creato la dir.

    Se tutto a posto prova con :

    mount -t ntfs-3g /dev/sda1 /media/sda1 -o force

    fammi sapere

  • #24229

    Mr_Oiz
    Membro

    Ciao CasimiroAndrea…

    Guarda, probabilmente hai qualche programma sotto windows, che quando chiude, non chiude qualche file sul tuo hard disk esterno.

    Come diceva Marco, “smonta” il tuo hard disk…

    Eh, eh, eh, eh….

    Ossia vai su “rimozione sicura dell’hardware” e prima di chiudere o congelare la sessione di windows (che comunque poi se usi questa procedura ti darà qualche problema comunque, per cui CHIUDI sempre, MAI sospendere windows o metterlo in stand by per accedere ad una sessione di Linux) e rimuovi l’hard disk esterno.

    Prova anche questo tentativo se ancora non l’hai fatto…

    A me spesso con qualche applicazione – e succede anche con Linux, tanto che windows, quando parte sistema la cosa forzatamente – l’hard disk resta sotto vincolo di windows, ed uso sempre questo sistema da quando ho scoperto la cosa.

    Cercare quale è l’applicativo non è difficile; se è così, vedrai che per rimuoverlo dovrai chiudere tutti gli applicativi anche quelli che lavorano in background sotto windows…

    SD: Marco, ancora non ho messo le mani sul mio.. La prendo comoda per non arrabbiarmi inutilmente. 😉

  • #24231

    hackerberry
    Membro

    ciao HACKERBERRY grazie per il consiglio ma non ho capito cosa vuol dire smonta l’ hard disk da windows


    Semplicemente volevo dirti avvia il pc con l’hard disk inserito nella porta usb da windows.

    Poi dalle icone in basso a destra sulla barra dove c’è pure l’orologio dovresti trovare una funzione che ti permetta di smontare l’hard disk (l’opzione, vado a memoria perchè winzozz l’ho gettato via da un po’, dovrebbe chiamarsi rimozione sicura del dispositivo), se riesci a trovare questa funzione in windows, allora dovresti risolvere il problema

  • #24238

    Ciao casimiroandrea, sto visitando il forum da win… e, in basso a destra, l’icona che ti serve ha un rettangolo grigio tipo hd esterno visto in prospettiva ed una freccia verde sopra.

  • #24257

    ciao hackerberry,

    avevi ragione dopo aver smontato l’ hd ext da windows è tutto ok .

    grazie 1000

Devi essere loggato per rispondere a questa discussione.