Firefox, Your connection is not secure – NS_ERROR_NET_INADEQUATE_SECURITY

Home Page Forum utenti Firefox, Your connection is not secure – NS_ERROR_NET_INADEQUATE_SECURITY

Visualizzazione 5 filoni di risposte
  • Autore
    Articoli
    • #32600
      bottye
      Partecipante

      Ciao,

      ho riscontrato il problema su Firefox : NS_ERROR_NET_INADEQUATE_SECURITY

      Questo ha risolto il problema:

      This message seems to be associated with sites using the HTTP/2 protocol (only recently supported in Firefox) but not using an appropriate level of security for that protocol. So one option would be to set Firefox NOT to use http/2 so sites fall back to http/1.1. If it works, it would leave the mystery unsolved, and I think it’s better to solve the mystery in case it’s someone/something spying on you, but I’ll give you the steps anyway:

      (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

      (2) In the search box above the list, type or paste spd and pause while the list is filtered

      (3) Double-click the network.http.spdy.enabled.http2 preference to switch the value from true to false

      Tratto da:https://support.mozilla.org/en-US/questions/1136120

      🙂

    • #32602
      Silvan
      Amministratore del forum

      Ciao,
      grazie per il post del problema con la soluzione. Anche nel caso di Firefox, come di Chromium (ved. post precedente in questo forum), la priorità è di aggiornarlo ad una versione più recente in openmamba, in modo probabilmente da evitare a priori problemi di questo tipo.

    • #32603
      bottye
      Partecipante

      Ciao Silvan,

      come posso fare in autonomia i pacchetti mamba o installare le versioni più aggiornate?

      Spiego il motivo:

      In Apper vedo che è disponibile ed installato Firefox 1:50.1.0.1mamba
      (similmente in Chromium) quindi aggiornato a una versione molto recente,

      Purtroppo, su Amazon Prime per vedere i video, mi richiede la .52…

      Inoltre altri pacchetti che vorrei aggiornare senza far danni, (sono bravissimo in questo! 🙂 ) come li posso installare con dipendenze e tutto un po?

      C’è un programma che mi permetta di pacchettizzare in modo più o meno automatico?

      Grazie.

      P.S.: Ero in dubbio se questa discussione avrebbe dovuto essere inserita come nuovo post…

      E-

    • #32608
      Silvan
      Amministratore del forum

      Ciao,
      l’aggiornamento di Firefox non è ancora disponibile perché ci sono ancora delle problematiche di compilazione nonostante stia facendo parecchio lavoro per cercare di portarle a termine con successo (così come per Chromium).

      Le versioni recenti di Firefox richiedono il compilatore Rust, che è stato fatto in openmamba ma ha un problema:

      ../mach build
       [...]
       0:10.68 force-cargo-library-build
       0:12.11 xptcinvoke_asm_x86_64_unix.o
       0:14.07 error: no matching package named 'proc-macro' found
      

      Il package ‘proc-macro’ (ma il problema capita anche con altri package) è interno a Rust ed al momento falliscono anche le compilazioni di piccoli esempi di codice che richiedono ‘proc-macro’, quindi per trovare la soluzione bisognerebbe lavorare su Rust anziché su Firefox.

      Lo sviluppo di openmamba comunque avviene su dei build server gestiti tramite l’interfaccia web Webbuild, cui se vuoi puoi accedere dal menù di questo sito alla voce ‘Sviluppo’ -> ‘Webbuild’ -> ‘buildvm01 (x86_64)’. La prima volta devi richiede l’autorizzazione.

      In questo caso come consiglio se volessi provare ad aiutare a risolvere il problema potresti installare Rust sul tuo PC e cercare di compilare un piccolo frammento di codice che posso fornire e capire perché non lo compila.

      Sono a disposizione per supportare ogni contributo tuo o di altri utile a risolvere questo ed altri problemi di aggiornamento (riguardo a Chromium il discorso è ancora più lungo e nel caso lo scrivo in un altro posto dedicato).

    • #32609
      bottye
      Partecipante

      Ciao,
      al coll di Rust ho visto che c’è la versione Install Rust 1.27.0

      non dipenderà magari da Rust?

      E-

    • #32610
      Silvan
      Amministratore del forum

      Ciao,
      l’aggiornamento del pacchetto rust per openmamba non risolve ma usando la distribuzione binaria la compilazione di Firefox va a buon fine. Probabilmente c’è un problema di boostrap del compilatore rust, che magari si risolverà “boostrappandolo” con la versione binaria.
      Saranno quindi disponibili a breve l’aggiornamento del pacchetto firefox ed il nuovo pacchetto rust-bin che serve per compilarlo.

      • Questa risposta è stata modificata 3 anni, 3 mesi fa da Silvan.
Visualizzazione 5 filoni di risposte
  • Devi aver eseguito l’accesso per poter rispondere a questa discussione.