Dopo l’aggiornamento non si avviano più i programmi

Home Page Forum generale Dopo l’aggiornamento non si avviano più i programmi

Visualizzazione 5 filoni di risposte
  • Autore
    Articoli
    • #33902
      ercolinux
      Moderatore

      Ciao,
      dopo l’aggiornamento odierno non riesco più ad avviare nessun programma, qualsiasi programma ho tentato mi da l’errore “execvp no such file or directory”.

      La versione di openmamba è la 2023.08 rolling aggiornato ieri con successo.

    • #33903
      Silvan
      Amministratore del forum

      Ciao Ercole,
      l’aggiornamento sospetto tra quelli pubblicati oggi è il pacchetto filesystem. L’aggiornamento tuttavia aveva lo scopo di completare la migrazione a flat filesystem facendo il merge di /usr/sbin in /usr/bin.

      Da una prima verifica potrebbe essere stato rimosso il link /lib64 a /usr/lib64 e/o /lib a /usr/lib, in tal caso si potrebbero creare richiamando direttamente il linux loader con:
      `
      /usr/lib64/ld-linux-x86_64.so.2 /usr/bin/ln -s usr/lib64 /lib64
      /usr/lib64/ld-linux-x86_64.so.2 /usr/bin/ln -s usr/lib /lib

      Valuterei dopo altre possibilità se quanto sopra non dovesse risolvere.

      • Questa risposta è stata modificata 2 mesi, 3 settimane fa da Silvan.
    • #33905
      ercolinux
      Moderatore

      Ho provato ma il comando non funziona:

      /usr/bin/ln: creazione del collegamento simbolico ‘/lib64’ non riuscita: Permesso negato

      Probabilmente andrebbe eseguito come root, ma ne il comando sudo ne su non funzionano: la password non viene riconosciuta.

    • #33906
      Silvan
      Amministratore del forum

      Giusto, i comandi vanno eseguiti con i privilegi di root ma anche il sottosistema pam potrebbe non trovare la cartella /lib64/security.

      Tuttavia l’errore restituito è coerente con quella che che era l’ipotesi del problema ed a questo punto non ho suggerimento migliore che avviare con un sistema live, montare il filesystem di root e creare i link simbolici mancanti in /.

      In alternativa puoi provare, sempre dal sistema live e supponendo che il rootfs sia montato in /mnt/openmamba, ad installare l’aggiornamento di filesystem che adesso è disponibile con questo comando:
      `
      sudo rpm -U http://cdn.openmamba.org/pub/openmamba/base/RPMS.x86_64/filesystem-2.3-9mamba.noarch.rpm -r /mnt/openmamba
      `

      • Questa risposta è stata modificata 2 mesi, 3 settimane fa da Silvan.
    • #33908
      ercolinux
      Moderatore

      Ciao, solo creando i link non ha funzionato: il sistema si avviava ma non riusciva a far partire i servizi di rete (e alcun altri) e quindi era inusabile. Aggiornando il pacchetto filesystem invece è andato tutto bene.

      Grazie

    • #33909
      Silvan
      Amministratore del forum

      Ciao,
      probabilmente ricreando manualmente i link mancava ancora il symlink da /usr/sbin a /usr/bin.
      In ogni caso questa installazione dovrebbe aver superato il problema ma per completezza consiglio di controllare che in / o /usr non ci sia alcuna cartella che termini con .notmigrated, ad esempio /usr/sbin.notmigrated.

Visualizzazione 5 filoni di risposte
  • Devi aver eseguito l’accesso per poter rispondere a questa discussione.