dnf

Home Page Forum utenti dnf

Visualizzazione 12 filoni di risposte
  • Autore
    Articoli
    • #32839
      fredflinstone
      Partecipante

      Ciao !

      dopo l’ aggiornamento a dnf ho provato ad installare alcuni programmi ma alla fine del processo mi viene dato un errore di segmantazione.
      Esempio con wine :

      Dimensione totale dello scaricamento: 156 M
      Dimensione installata: 156 M
      Procedere : s
      Scaricamento dei pacchetti:
      (1/11): libcapi20-3.27-1mamba.i586.rpm 81 kB/s | 859 kB 00:10
      (2/11): ocl-icd-2.2.12-1mamba.i586.rpm 89 kB/s | 34 kB 00:00
      (3/11): samba-server-4.10.6-1mamba.i586.rpm 44 kB/s | 422 kB 00:09
      (4/11): samba-winbind-4.10.6-1mamba.i586.rpm 64 kB/s | 464 kB 00:07
      (5/11): wine-3.15-3mamba.i586.rpm 11 kB/s | 3.3 kB 00:00
      (6/11): libOSMesa-18.3.4-2mamba.i586.rpm 51 kB/s | 2.7 MB 00:53
      (7/11): wine-core-3.15-3mamba.i586.rpm 43 kB/s | 40 kB 00:00
      (8/11): wine-desktop-3.15-3mamba.i586.rpm 59 kB/s | 23 kB 00:00
      (9/11): wine-fonts-3.15-3mamba.i586.rpm 54 kB/s | 2.4 MB 00:46
      ^[[A(10-11/11): libwine-3.15 49% [=========== ] 29 kB/s | 77 MB 46:48 (10/11): libwine-3.15-3mamba.i586.rpm 47 kB/s | 48 MB 17:21
      (11/11): wine-common-3.15-3mamba.i586.rpm 59 kB/s | 101 MB 29:03
      —————————————————————————————
      Totale 90 kB/s | 156 MB 29:31
      Esecuzione del controllo di transazione
      Errore di segmentazione

      Il comando ” sudo dnf install ” è stato lanciato da riga di comando.

      Ho provato anche con altre installazioni ma il risultato è il medesimo.

      Che fare ?

      Grazie.

      • Questo argomento è stato modificato 2 anni, 1 mese fa da fredflinstone.
    • #32841
      Silvan
      Amministratore del forum

      Ciao,
      potresti eseguire i seguenti comandi e copiare qui il risultato? Grazie.

      
      uname -a
      rpm -q rpm dnf libdnf python-rpm
      sudo dnf update
      sudo dnf install wine
      dmesg | grep segfault
      

      Silvan

    • #32842
      fredflinstone
      Partecipante

      Ciao !

      Ecco il risultato :

      ” rpm -q rpm dnf libdnf python-rpm
      rpm-5.2.1-36mamba.i586
      il pacchetto dnf non è stato installato
      il pacchetto libdnf non è stato installato
      python-rpm-5.2.1-36mamba.i586
      [claudio@blackmamba ~]$ sudo dnf update ”

      Lanciando update ecco cosa salta fuori :

      Ultima verifica della scadenza dei metadati: 1:25:42 fa il sab 27 lug 2019, 10:44:57.
      Errore:
      Problema: cannot install both rpm-1:4.14.2.1-11mamba.i586 and rpm-5.2.1-36mamba.i586
      – package NetworkManager-1.18.1-1mamba.i586 requires rpmlib(PartialHardlinkSets) <= 4.0.4-1, but none of the providers can be installed
      – cannot install the best update candidate for package rpm-5.2.1-36mamba.i586
      – cannot install the best update candidate for package NetworkManager-1.18.1-1mamba.i586
      (try to add ‘–allowerasing’ to command line to replace conflicting packages or ‘–skip-broken’ to skip uninstallable packages or ‘–nobest’ to use not only best candidate packages)

      ultimo comando

      dmesg | grep segfault
      [ 29.379041] rpm[3674]: segfault at e9671d98 ip b7ebad74 sp bff56da0 error 5 in librpm.so.8.1.0[b7eac000+4a000]
      [ 3397.357823] dnf[6423]: segfault at a420b444 ip b66d9d74 sp bf962830 error 4 in librpm.so.8.1.0[b66cb000+4a000]
      [ 3435.893536] dnf[6446]: segfault at a4ab3d14 ip b6619d74 sp bfd83850 error 4 in librpm.so.8.1.0[b660b000+4a000]
      [ 6217.748236] dnf[8515]: segfault at b2d9c1d8 ip b66c9d74 sp bfa037f0 error 4 in librpm.so.8.1.0[b66bb000+4a000]

      grazie

      • Questa risposta è stata modificata 2 anni, 1 mese fa da fredflinstone.
      • Questa risposta è stata modificata 2 anni, 1 mese fa da fredflinstone.
    • #32845
      Silvan
      Amministratore del forum

      Il sistema non è aggiornato per usare rpm4 e dnf.
      Cosa restituisce il comando:

      sudo yum update

      ?

    • #32846
      fredflinstone
      Partecipante

      Ciao !

      ecco :

      sudo yum update
      adobe-linux-i386 | 2.9 kB 00:00:00
      rolling/signature | 181 B 00:00:00
      Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-Mambasoft
      Errore di segmentazione

      grazie

    • #32847
      Silvan
      Amministratore del forum

      Deve esserci stato un errore precedente durante l’aggiornamento a rpm4.

      Suggerisco di eseguire questo comando:
      sudo rpm -U http://cdn.openmamba.org/pub/openmamba/devel/RPMS.i586/librpm-4.14.2.1-11mamba.i586.rpm http://cdn.openmamba.org/pub/openmamba/devel/RPMS.i586/rpm-4.14.2.1-11mamba.i586.rpm http://cdn.openmamba.org/pub/openmamba/devel/RPMS.i586/python-rpm-4.14.2.1-11mamba.i586.rpm --force

      e se ha successo poi:
      sudo yum update

    • #32848
      fredflinstone
      Partecipante
    • #32849
      Silvan
      Amministratore del forum

      Anche

      sudo rpm --rebuilddb

      restituisce Errore di segmentazione?

    • #32850
      fredflinstone
      Partecipante

      lanciato il comando ” sudo rpm –rebuilddb ” non succede nulla, apparentemente …

    • #32851
      Silvan
      Amministratore del forum

      Ti chiedo se puoi ancora eseguire (e riportare il risultato):

      rpm --version
      sudo rpm -U http://cdn.openmamba.org/pub/openmamba/devel/RPMS.i586/librpm-4.14.2.1-11mamba.i586.rpm http://cdn.openmamba.org/pub/openmamba/devel/RPMS.i586/rpm-4.14.2.1-11mamba.i586.rpm http://cdn.openmamba.org/pub/openmamba/devel/RPMS.i586/python-rpm-4.14.2.1-11mamba.i586.rpm --force

      (il secondo è di nuovo il comando di prima)

    • #32852
      fredflinstone
      Partecipante

      Ecco :

      rpm –version
      RPM versione 4.14.2.1
      [claudio@blackmamba ~]$ sudo rpm -U http://cdn.openmamba.org/pub/openmamba/devel/RPMS.i586/librpm-4.14.2.1-11mamba.i586.rpm http://cdn.openmamba.org/pub/openmamba/devel/RPMS.i586/rpm-4.14.2.1-11mamba.i586.rpm http://cdn.openmamba.org/pub/openmamba/devel/RPMS.i586/python-rpm-4.14.2.1-11mamba.i586.rpm –force
      errore: Dipendenze fallite:
      libnettle.so.7 necessario a rpm-1:4.14.2.1-11mamba.i5

    • #32853
      Silvan
      Amministratore del forum

      Ok, dopo l’esecuzione di rpm --rebuilddb va meglio.
      Riproverei con il comando di cui sopra con l’aggiunta di libnettle:

      sudo rpm -U http://cdn.openmamba.org/pub/openmamba/devel/RPMS.i586/librpm-4.14.2.1-11mamba.i586.rpm http://cdn.openmamba.org/pub/openmamba/devel/RPMS.i586/rpm-4.14.2.1-11mamba.i586.rpm http://cdn.openmamba.org/pub/openmamba/devel/RPMS.i586/python-rpm-4.14.2.1-11mamba.i586.rpm http://cdn.openmamba.org/pub/openmamba/devel/RPMS.i586/libnettle-3.5.1-2mamba.i586.rpm --force

      e se va a buon fine:
      sudo yum update

      • Questa risposta è stata modificata 2 anni, 1 mese fa da Silvan.
    • #32855
      fredflinstone
      Partecipante

      Tutto sembra andato a buon fine
      ora procedo con l’ aggiornamento….

      sembra anche questo andato bene.

      grazie.

Visualizzazione 12 filoni di risposte
  • Devi aver eseguito l’accesso per poter rispondere a questa discussione.