crash di knotify4

Home Page Forum utenti crash di knotify4

  • Questo topic ha 12 risposte, 2 partecipanti ed è stato aggiornato l'ultima volta 8 anni, 7 mesi fa da gigi.
Visualizzazione 12 filoni di risposte
  • Autore
    Articoli
    • #21571
      gigi
      Membro

      ciao a tutti!

      proseguo a segnalare il problema del crash che ho con knotify perchè la situazione peggiora…

      ho ora problemi di stabilità anche durante la visualizzazione delle informazioni popup per le immagini, durante il cambio di cartella con le anteprime attivate e non riesco ad accedere alla sezione multimedia di systemsettings.

      ho provato ad installare i tutti backend per phonon (gstreamer,xine,vlc) senza cambiamenti ma l’audio funziona regolarmente; nessun messaggio nei log di sistema, mi sembra .

      E’fastidioso perché la finestrella compare spesso e soprattutto al logout (a tradimento!)….

      plis elp!

    • #28141
      Silvan
      Amministratore del forum

      Ciao,

      prima cosa serve sapere se si tratta di versione devel o milestone2 (scusa ma scriverlo è più veloce rispetto a che vada a rileggere i tuoi post precedenti, inoltre in ogni caso potresti avere diverse installazioni. Poi quando avrò tempo aggiungerò un campo per specificarlo nel forum).

      Poi, se e quando ci sono dei crash la metodologia universale consiste nel vedere il backtrace. Normalmente se dici che è andato in crash knotify dovrebbe essere perché hai visto comparire una finestra che serve apposta per generare il backtrace e che fornisce dettagliate spiegazioni e istruzioni in merito. Questo (o questi) backtrace dovrebbe poi essere allegato qua o inviato a reports <at> openmamba.org. Sempre a questo indirizzo sarebbe utile ricevere un report del sistema data la tipologia del problema che descrivi. Grazie.

    • #28144
      gigi
      Membro

      milestone2 ma milestone2-kernel-next disabilitato.

      knotify non è l’unico ad avere problemi; kdialog e dolphin cadono con gli stessi messaggi quando si cerca di accedere a immagini o cartelle con immagini.

      la cosa problematica è che non riesco ad accedere alla sezione multimedia del systemsettings, ne come utente abituale, root o altro utente (nuovo, creato per ripartire con settaggi base).

      non credo di aver sballato io il sistema con azioni spericolate…

      ti invio 3 backtrace generati dai citati programmi.

      ciao e grazie

    • #28145
      Silvan
      Amministratore del forum

      Dev’essere un problema legato al driver snd_via82xx. Mi puoi copiare ciò che restituisce il seguente comando dato da un terminale?

      cat /proc/asound/cards

      Grazie.

    • #28146
      Silvan
      Amministratore del forum

      Anzi, proverei ad editare da root il file /etc/asound.conf e scommentare le due righe:

      #buffer_size 4096

      in modo che diventino:

      buffer_size 4096

      Riferimenti:

      http://alsa.opensrc.org/DmixPlugin (fai un find di ‘snd-via82xx’ nella pagina)

      http://us.generation-nt.com/answer/alsa-dmix-via82xx-limitations-help-173577871.html

      Eventualmente se non cambia niente prova anche sostituendo 4096 con 2048.

      Altra cosa: i pacchetti di alsa sul tuo computer provengono dal repository milestone2-makedist, questo sarebbe meglio disabilitarlo per gli aggiornamenti automatici in quanto contiene pacchetti in lavorazione e potenzialmente instabili. Niente in contrario invece se vuoi abilitare milestone2-kernel-next.

      Altra cosa 2: se quanto sopra non funziona ti chiedo anche l’output del seguente comando:

      alsaplayer -d dmix

    • #28237
      gigi
      Membro

      ciao, perdonami la lentezza ma mi è arrivato un altro figlio e ciò mi impegna un pò….

      cat /proc/asound/cards

      0 [V8235 ]: VIA8233 – VIA 8235

      VIA 8235 with ALC200,200P at 0xe100, irq 5

      1 [modem ]: VIA82XX-MODEM – VIA 82XX modem

      VIA 82XX modem at 0xe200, irq 5


      alsaplayer -d dmix

      Playing (1/1): 0:01 (0:01) Front_Center.wav

      …done playing


      provato la cosa del buffer ma senza effetto.

      cambiato repos come da suggerimenti.

      non capisco cosa genera l’errore…

      soprattutto come mai non riesco ad accedere alla sezione multimedia del pannello di controllo e come mai ogni volta che passo su un png in dolphin ho un crash di questo…

      questo influenza anche i dialoghi di apertura e salvataggio rendendo queste operazioni piuttosto difficili.

      riesci a darmi altre dritte?

      ps:

      ho installato syslog-ng per avere il file messages ma mi piacerebbe avere anche syslog,

      come fo?

    • #28238
      Silvan
      Amministratore del forum

      Ciao e auguri,

      il comando alsaplayer -d dmix dovrebbe restituire varie righe di informazioni utili, non so perché il tuo output sia solo di due righe. Prova a chiudere il browser e qualunque cosa che possa usare il suono prima di lanciare il comando.

      Sto cercando la soluzione corretta del problema ma nel peggiore dei casi lanciando:

      sudo update-alternatives --config asound.conf

      e selezionando il numero corrispondente a /etc/asound.conf.dummy disattivi il mixing dei suoni di alsa e non dovresti più avere i crash ma così solo un’applicazione alla volta potrà emettere suoni, quindi non è un granché come soluzione ma magari riesci a usare meglio il sistema nel frattempo.

      Riguardo alla domanda sul syslog, non so se vorresti avere il vecchio syslog di cui syslog-ng è una versione più recente e comunemente diffusa. Se è giusto quello che ho capito, la risposta è che in openmamba l’unica versione mantenuta è syslog-ng e che non sono noti motivi per cui bisognerebbe mantenere anche il vecchio syslog.

    • #28241
      gigi
      Membro

      ciao silvan

      il suono funziona con tutti i player audio e video, e avevo disabilitato i suoni di sistema kde!

      mi sembra che il problema stia nei dialoghi di kde, forse nelle funzioni grafiche…

      poi se non riesco ad accedere alla configurazione del sistema multimediale kde, mi viene da pensare a phonon e gstreamer che era l’ultimo motore selezionato prime dei problemi…

      se provassi a reinstallare qualche pacchetto del sistema base? ma quali?

      x syslog: non sono aggiornato tecnicamente… ero abituato a guardare dentro messages, debug e syslog per trovare i problemi ma mamba mi fornisce solo messages…

    • #28242
      Silvan
      Amministratore del forum

      I suoni di kde escono tramite il plugin dmix e i backtrace che mi hai mandato mostrano che il crash avviene in questo plugin. Che il problema non si verifichi disattivando i suoni di kde non mi stupisce ma la causa del problema pare essere nel basso a livello di alsa, dove si stava indagando.

      Application: KDialog (kdialog), signal: Aborted
      [KCrash Handler]
      #6 0x4321dfa7 in raise () from /lib/libc.so.6
      #7 0x4321fa82 in abort () from /lib/libc.so.6
      #8 0xafd91a6b in snd_pcm_dmix_close () from /usr/lib/libasound.so.2
      ...

      Comunque se in passato il sistema funzionava correttamente potrebbe essere il caso di retrocedere i pacchetti di alsa in quanto tu dovresti avere installate le versioni che provengono dal repository milestone2-makedist che, se non mi confondo con un’altra segnalazione, avevi attivo.

      L’operazione si effettua con un comando del genere:

      sudo smart install libalsa-1.0.25 alsa-utils-1.0.25 libalsa-plugins-1.0.25

      Altrimenti come workaround puoi configurare il sistema del suono di kde per usare un dispositivo di riproduzione hardware diverso da “System default (recommended)”, ma ovviamente questo è un workaround mentre la soluzione del problema per me rimane quella per la quale stavo scrivendo fino al post precedente ma che non so come risolvere senza ulteriori informazioni o senza poterci lavorare direttamente.

    • #28243
      Silvan
      Amministratore del forum

      Sulla milestone2 i file di log di sistema sono come configurati in /etc/syslog-ng.conf. Puoi agire su questa configurazione per personalizzare i file come preferisci e se ricavi una soluzione migliore e più ordinata non solo per i tuoi gusti possiamo poi anche integrarla upstream.

    • #28247
      gigi
      Membro

      bingo!

      avevo alsa 1.0.27

      retrocesso a 1.0.25 e sembra tutto ritornato all’ordine!

      ora non sarebbe male vedere se ci sono altri pacchi dai repo experimental…

      come si fa?

      ciao e grazie

    • #28248
      Silvan
      Amministratore del forum

      Ciao,

      per retrocedere i pacchetti puoi guardare nel canale milestone2-makedist e fare a mano in quanto non mi pare che ci sia una procedura automatica.

    • #28249
      gigi
      Membro

      modemmanager libxcb ethtool mobile-broadband-provider-info usb-mode-switch usb-mode-switch-data erano in makedist e li ho retrocessi anche se mi sembrava lavorassero normalmente.

      ciao

Visualizzazione 12 filoni di risposte
  • Devi aver eseguito l’accesso per poter rispondere a questa discussione.