aggiornamento… in conflitto

Home Page Forum utenti aggiornamento… in conflitto

Visualizzazione 8 filoni di risposte
  • Autore
    Articoli
    • #33097
      fredflinstone
      Partecipante

      ” Errore durante l’esecuzione della transazione: il file /usr/lib/.build-id/16/43f089f0370ccf5e489842ed8c095952f168ea dell’installazione di kernel-mamba-64GB-headers-4.19.88-1mamba.i586 entra in conflitto con il file del pacchetto kernel-mamba-headers-4.19.88-1mamba.i586 ”

      Questo è il messaggio che mi appare durante l’ aggiornamento.
      Il mio pc utilizza gli headers per .586.

      Come posso evitare l’ aggiornamento degli headers a 64GB ?

      Grazie

      • Questo argomento è stato modificato 1 anno, 7 mesi fa da fredflinstone.
    • #33099
      Silvan
      Amministratore del forum

      Ciao,
      premessa: il conflitto riguarda l’installazione degli headers del kernel “mamba” e “mamba-64GB”. Attenzione perché si tratta in entrambi i casi di kernel per piattaforme Intel compatibili a 32bit, la differenza è nella gestione della memoria. Il kernel mamba è da usarsi su (vecchi) PC che hanno meno di 4GB di RAM, il kernel mamba-64GB è per (vecchi) PC con 4 o piu’ GB di RAM.

      Il problema del conflitto deriva dalla gestione dei build-id presente da quando è stato effettuato il passaggio a rpm 4 e probabilmente lo risolverò al prossimo aggiornamento del kernel.

      Intanto per risolvere potresti rimuovere uno dei due pacchetti tra “kernel-mamba-headers” e “kernel-mamba-64GB-headers” a seconda di quale kernel hai in uso, cosa che si capisce eseguendo il comando:

      uname -r

      Se il tuo PC ha, ad esempio, 4GB di RAM il kernel in uso dovrebbe essere kernel-mamba-64GB quindi potresti rimuovere gli header dell’altro kernel con il seguente comando:

      sudo rpm -e kernel-mamba-headers --allmatches

      Per fare una maggiore pulizia oltre agli headers potresti rimuovere anche il kernel stesso:

      sudo rpm -e kernel-mamba --allmatches

      • Questa risposta è stata modificata 1 anno, 7 mesi fa da Silvan.
    • #33102
      fredflinstone
      Partecipante

      Ciao !

      Ti ringrazio. il mio pc è vecchio ed ha meno di 4 GB di memoria.

      Cercando quindi di eliminare quello che non mi serve coi comandi proposti, mi viene data questa risposta :
      ” sudo rpm -e kernel-mamba-headers-64GB –allmatches
      errore: il pacchetto kernel-mamba-headers-64GB non è stato installato ”

      Grazie.

    • #33103
      Silvan
      Amministratore del forum

      Il comando corretto dovrebbe essere:
      sudo rpm -e kernel-mamba-64GB-headers --allmatches

    • #33104
      fredflinstone
      Partecipante

      Ciao !

      ” sudo rpm -e kernel-mamba-64GB-headers –allmatches
      errore: il pacchetto kernel-mamba-64GB-headers non è stato installato ”

      Stessa risposta.

      Grazie.

    • #33105
      Silvan
      Amministratore del forum

      Puoi copiare qui quello che viene restituito dal seguente comando?

      rpm -qa | grep kernel

      e anche da:

      uname -a

      • Questa risposta è stata modificata 1 anno, 7 mesi fa da Silvan.
    • #33107
      fredflinstone
      Partecipante

      Ecco :

      kernel-mamba-64GB-4.14.60-1mamba.i586
      kernel-mamba-headers-4.19.57-1mamba.i586
      kernel-mamba-4.19.88-1mamba.i586
      kernel-mamba-4.19.57-1mamba.i586
      kernel-mamba-64GB-4.14.94-1mamba.i586
      kernel-mamba-headers-4.19.88-1mamba.i586
      kernel-mamba-64GB-4.19.57-1mamba.i586

      • #33108
        fredflinstone
        Partecipante

        ecco :
        uname -a
        Linux blackmamba 4.19.88mamba #1 SMP PREEMPT Tue Dec 10 17:49:43 CET 2019 i686 i686 i686 GNU/Linux

        Grazie.

    • #33110
      Silvan
      Amministratore del forum

      Non saprei al momento per quale motivo ti venga proposta l’installazione di kernel-mamba-64GB-headers visto che non risulta installato, comunque rimuoverei le versioni che hai installate di kernel-mamba-64GB:

      sudo rpm -e kernel-mamba-64GB --allmatches

    • #33112
      fredflinstone
      Partecipante

      Fatto !
      Sparita la proposta d’aggiornamento.
      Grazie.

Visualizzazione 8 filoni di risposte
  • Devi aver eseguito l’accesso per poter rispondere a questa discussione.